Bug 813294 - Add standard human task properties into designer
Add standard human task properties into designer
Status: VERIFIED
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor) (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity high
: ER7
: BRMS 5.3.0.GA
Assigned To: Tihomir Surdilovic
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 08:18 EDT by Jiri Locker
Modified: 2012-05-27 21:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Locker 2012-04-17 08:18:11 EDT
Description of problem:
Human task node has a set of standard properties. It should be possible to access them directly in the Properties panel in designer. The missing properties are Id, Priority, Comment, Skippable, Content, Swimlane.

Version-Release number of selected component (if applicable):
ER5

Actual results:
Some of the standard human task node properties are accessible (Actors, GroupID, Name, TaskName, ...) but the mentioned parameters are missing. It is possible to set them by adding them into DataInputSet property and setting the value inside Assignments property. But it is not very user friendly and seems like a kind of hack to me. DataInputSet and Assignments should be used for Parameter mapping.

Expected results:
Id, Priority, Comment, Skippable, Content, Swimlane should be added to the Properties panel for Human task nodes.
Comment 1 Tihomir Surdilovic 2012-04-17 08:37:09 EDT
Comment and Skippable are already available as individual attributes of Task nodes. 
Designer uses visual representation of Swimlanes so there is no need to have this property available (I guess it is needed in Eclipse as Swimlanes are not visually presented). 
AFAIK Priority is an attribute of a sequence flow. 
Not sure Content is a user-task specific property..can you show me an example?
Comment 2 Jiri Locker 2012-04-17 13:36:50 EDT
(In reply to comment #1)
> Comment and Skippable are already available as individual attributes of Task
> nodes.

Does it mean these two have been added in the most recent version of designer? If not, where can I find them? Task node Property panel really doesn't contain these two in ER5.

> Designer uses visual representation of Swimlanes so there is no need to have
> this property available (I guess it is needed in Eclipse as Swimlanes are not
> visually presented).

Agreed.

> AFAIK Priority is an attribute of a sequence flow. 

Yes, sequence flow has a priority, but so does Human task: http://docs.jboss.org/jbpm/v5.2/userguide/ch05.html#d0e1224

Priority is also included in generated task form templates but it is not included in the Properties panel, so the only way to set it is using DataInputSet + Assignments.

> Not sure Content is a user-task specific property..can you show me an example?

I'm not sure either, but it's in the docs :-)
Comment 3 Tihomir Surdilovic 2012-04-17 16:33:19 EDT
Yes, Comment and Skippable are available in the Designer master, 2.1.x and 2.2.x branches. Should be available in the next ER build.

Will add Priority.

Will check on Content and add if needed.

Thanks!
Comment 4 Tihomir Surdilovic 2012-04-19 21:13:14 EDT
Added both Priority and Content to the properties of a Task node. Checked into designer master and 2.2.x branches.
Comment 5 Ryan Zhang 2012-04-23 03:35:58 EDT
Update status to ON_QA. Please verify them against ER6.
Comment 6 Ryan Zhang 2012-04-23 04:18:59 EDT
Confirmed that it is not picked in ER6. So change the status back.
Comment 7 Jiri Locker 2012-04-24 12:32:22 EDT
Tiho, could you change the editor for Skippable from drop-down list to a checkbox? This is just to be consistent with other boolean properties (see Instatiate property).
Comment 8 Ryan Zhang 2012-05-14 04:16:06 EDT
The fixed for this issue should be included in ER7. Please do verification on it.
Comment 10 Petr Široký 2012-05-22 07:28:27 EDT
Verified fixed in 5.3.0 ER7. The Skippable attribute is still presented as drop-down list (instead of checkbox), but I will report that as new low priority issue as it is not a bug.

Note You need to log in before you can comment on or make changes to this bug.