Bug 813297 - Got Traceback with changed hostname
Got Traceback with changed hostname
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-04-17 08:31 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:50:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-04-17 08:31:02 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites : 
Rhel6.3 with following subscription-manager rpm .
subscription-manager-migration-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-gnome-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-firstboot-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-migration-data-1.12.1.3-1.git.0.1b05607.el6_2.noarch

Steps to Repro : 
Login to client console .
Change hostname using following command 
hostname test2
Now launch subscription-manager-gui using subscription-manager-gui command. 

Expected Result : 
Command should successfully executed , and it should open subscription-manager gui 

Actual Result : 
Got Following traceback.

[root@test1 ~]# hostname test2
[root@test1 ~]# subscription-manager-gui 
/usr/sbin/subscription-manager-gui:31: DeprecationWarning: The dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  import dbus.dbus_bindings
No protocol specified
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager-gui", line 32, in <module>
    import gtk
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
    _init()
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
    _gtk.init_check()
RuntimeError: could not open display
Comment 3 RHEL Product and Program Management 2012-07-10 04:47:29 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:49:13 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 RHEL Product and Program Management 2012-12-14 03:47:40 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Bryan Kearney 2013-10-09 17:32:20 EDT
I now see a a can not display error, which is resolved by logging out nad back in. Calling this fixed.
Comment 7 Sharath Dwaral 2013-10-11 14:21:23 EDT
Version:
# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.2-1.el7
python-rhsm: 1.10.2-1.el7


Verification

=== Original hostname ===
# hostname
sharath-70server.usersys.redhat.com

=== Changing hostname ===
# hostname test2

=== Checking Hostname ===
# hostname
test2

=== Launching GUI ===
# subscription-manager-gui
X11 connection rejected because of wrong authentication.
Unable to open a display

=== Exiting ssh ===
# exit
logout

=== Logging back in ===
$ dtop-client70 
root@sharath-70server.usersys.redhat.com's password: 
Last login: Fri Oct 11 11:24:08 2013 from dhcp129-238.rdu.redhat.com

=== Checking hostname ===
# hostname
test2

=== Launching GUI ===
# subscription-manager-gui

GUI launches successfully
This is an acceptable behavior

VERIFIED
Comment 8 Ludek Smid 2014-06-13 05:50:46 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.