Bug 813352 - ecj in Fedora should be updated to latest version that supports Java 7
ecj in Fedora should be updated to latest version that supports Java 7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ecj (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jon VanAlten
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 886013
  Show dependency treegraph
 
Reported: 2012-04-17 10:46 EDT by Deepak Bhole
Modified: 2013-01-24 16:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-24 16:50:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
akurtako: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Deepak Bhole 2012-04-17 10:46:55 EDT
The current version of ecj in Fedora is quite old (3.4). It should be updated to the latest 3.7 version so that Java 7 is supported.
Comment 1 Jon VanAlten 2012-04-25 13:33:17 EDT
3.4 is quite old indeed.  Even 3.7 is fairly old.  I notice that Eclipse itself is at 4.2 for F17; should ecj align with that?
Comment 2 Deepak Bhole 2012-04-25 13:43:47 EDT
I see no issues with jumping to 4.2. Alex, any problems you forsee?
Comment 3 Alexander Kurtakov 2012-04-25 13:55:59 EDT
Well, 4.2 and 3.8 should be exactly the same with ecj keeping the 3.8 version and it's not yet released but should be fairly stable now so jumping on 3.8/4.2 seems like the right call to me.
Comment 4 Jon VanAlten 2012-10-10 10:55:09 EDT
Hi,

I did most of the necessary work to update this months ago, but it slipped through a crack somehow!  Since 4.2.1 is now available, I've updated to that and committed (but not pushed a build) to rawhide branch.  Before I push a build, or apply to F18/F17 branches, is there any particular use case that I should make sure is working?  I've smoke tested this by successfully compiling code containing Java7 features (diamond operator, etc).  It requires -source argument, but resulting compilation seems ok.

Here's a scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=4576092
Comment 5 Alexander Kurtakov 2012-10-10 11:13:02 EDT
Verify that tomcat successfully compiles a hello workd jsp. If someone cares about gcj still you might want to verify it can still compile things.
Comment 6 Fedora Update System 2012-10-11 00:23:51 EDT
ecj-4.2.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ecj-4.2.1-2.fc18
Comment 7 Jon VanAlten 2012-10-11 01:39:58 EDT
Seems that everything is working as expected.  Rawhide is set, f18 has update pending (test and add karma as you wish).

Unfortunately. for f17 this does not seem to fall under an existing exception class for a major update.

https://fedoraproject.org/wiki/Updates_Policy#Exceptions

Although, I believe that with good backwards compatibility and the fact that other java tools are updated to support new language standard, this should be allowed.  So I've put in FESCO ticket.

https://fedorahosted.org/fesco/ticket/958
Comment 8 Fedora Update System 2012-10-18 18:38:53 EDT
ecj-4.2.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ecj-4.2.1-1.fc17
Comment 9 Fedora Update System 2012-10-19 19:59:19 EDT
Package ecj-4.2.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ecj-4.2.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16497/ecj-4.2.1-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-10-20 00:39:30 EDT
ecj-4.2.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Andreas Girgensohn 2012-12-30 17:37:35 EST
tomcat-7.0.34-1.fc17 (http://koji.fedoraproject.org/koji/taskinfo?taskID=4817874) doesn't seem to build because this package hasn't been pushed to stable.  That prevents the resolution of bug 889395 for Fedora 17.  I noticed that ecj-4.2.1-1.fc17 has been in testing for more than two months.

How would I test ecj to leave karma?  Just install it with the existing Tomcat 7 and create a new JSP?
Comment 12 Jon VanAlten 2013-01-02 17:23:09 EST
h(In reply to comment #11)
> tomcat-7.0.34-1.fc17
> (http://koji.fedoraproject.org/koji/taskinfo?taskID=4817874) doesn't seem to
> build because this package hasn't been pushed to stable.  That prevents the
> resolution of bug 889395 for Fedora 17.  I noticed that ecj-4.2.1-1.fc17 has
> been in testing for more than two months.
> 
> How would I test ecj to leave karma?  Just install it with the existing
> Tomcat 7 and create a new JSP?

Hi,
The build in testing has a known and really annoying bug, I've just unpushed it.  There is fix, I just didn't get to building that before holidays... honestly, so little seems to care about ecj anymore that it kept getting pushed down my list.  Sorry!  Now that it actually blocks something, I will prioritize it.  Expect new update (karma please!) when I return Jan 8.
I'm not exactly familiar with tomcat internals but that seems a reasonable way to test for karma purposes.  Anything to confirm that it Just Works as far as you can tell.
Comment 13 Andreas Girgensohn 2013-01-14 17:46:23 EST
I'm wondering if there is any news on ecj for Fedora 17.  The version from 2012-10-18 is still the most recent one in testing.
Comment 14 Fedora Update System 2013-01-14 18:58:45 EST
ecj-4.2.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ecj-4.2.1-2.fc17
Comment 15 Jon VanAlten 2013-01-14 19:07:16 EST
(In reply to comment #13)
> I'm wondering if there is any news on ecj for Fedora 17.  The version from
> 2012-10-18 is still the most recent one in testing.

Thanks for timely reminder, and for your patience!  See previous comment, new update has been sent.  Please do test and apply karma as appropriate.

If you're wondering, it was bug 869578 that had shown up in first update, so I had elected not to push the initial build, and even preferred to let the fix soak in rawhide a bit before backporting.
Comment 16 Andreas Girgensohn 2013-01-21 20:43:19 EST
Thanks for the update.  It works for me with tomcat-7.0.33-2.fc17.  Before restarting Tomcat, it produced a stack trace when attempting to compile something.  I should have realized that that would be required.
Comment 17 Fedora Update System 2013-01-24 16:50:53 EST
ecj-4.2.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.