Bug 813359 - bluetooth connection with phonefails
bluetooth connection with phonefails
Status: CLOSED DUPLICATE of bug 733847
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 11:05 EDT by Lukas Bezdicka
Modified: 2012-05-14 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 09:08:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukas Bezdicka 2012-04-17 11:05:30 EDT
Description of problem:
I can't connect to internet by using my mobile phone and bluetooth.

How reproducible:
always

Steps to Reproduce:
1. Search for bluetooth devices
2. Pair with device
3. after key check it fails
  
Additional info:
I'm getting following message from bluetoot-wizard:
(bluetooth-wizard:6284): GLib-GIO-WARNING **: Type of return value is incorrect, got `(s)', expected `()'
Comment 1 Toby Haynes 2012-04-27 14:41:16 EDT
I'm seeing similar behaviour on Fedora 17, x86_64. 

The following is an attempt to pair a HTC Wildfire S A510e Android phone with a Lenovo W510 laptop.

From the .xsession errors for multiple attempts (you can tell which windows I'm using because they get "Window Title:" lines courtesy of devilspie).

Agent registration failed: GDBus.Error:org.bluez.Error.AlreadyExists: Already Exists
Agent unregistration failed: GDBus.Error:org.bluez.Error.DoesNotExist: Does Not Exist 'g-io-error-quark'
Agent unregistration failed: GDBus.Error:org.bluez.Error.DoesNotExist: Does Not Exist 'g-io-error-quark'
Agent unregistration failed: GDBus.Error:org.bluez.Error.DoesNotExist: Does Not Exist 'g-io-error-quark'
Agent unregistration failed: GDBus.Error:org.bluez.Error.DoesNotExist: Does Not Exist 'g-io-error-quark'
Window Title: 'Bluetooth New Device Setup'; Application Name: 'bluetooth-wizard'; Class: 'Bluetooth-wizard'; Geometry: 729x466+436+393
(bluetooth-wizard:20037): GLib-GIO-WARNING **: Type of return value is incorrect, got `(s)', expected `()'
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,147565)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,147565)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,147565)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,147565)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,147565)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,147565)@/usr/share/gjs-1.0/lang.js:204
(bluetooth-wizard:20037): Bluetooth-CRITICAL **: bluetooth_client_create_device: assertion `address != NULL' failed
Window Title: 'Bluetooth New Device Setup'; Application Name: 'bluetooth-wizard'; Class: 'Bluetooth-wizard'; Geometry: 729x466+436+393
(bluetooth-wizard:21128): GLib-GIO-WARNING **: Type of return value is incorrect, got `(s)', expected `()'
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,489365)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,489365)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,489365)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,489365)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,489365)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,489365)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,845386)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,845386)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,845386)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,845386)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,845386)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,845386)@/usr/share/gjs-1.0/lang.js:204
Window Title: 'Bluetooth New Device Setup'; Application Name: 'bluetooth-wizard'; Class: 'Bluetooth-wizard'; Geometry: 729x466+436+393
Window Title: 'PIN Options'; Application Name: 'bluetooth-wizard'; Class: 'Bluetooth-wizard'; Geometry: 359x321+623+490
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,448063)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,448063)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,448063)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,448063)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,448063)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,448063)@/usr/share/gjs-1.0/lang.js:204
Window Title: 'Bluetooth New Device Setup'; Application Name: 'bluetooth-wizard'; Class: 'Bluetooth-wizard'; Geometry: 729x466+436+393
Window Title: 'Bluetooth New Device Setup'; Application Name: 'bluetooth-wizard'; Class: 'Bluetooth-wizard'; Geometry: 729x466+436+393
(bluetooth-wizard:25960): GLib-GIO-WARNING **: Type of return value is incorrect, got `(s)', expected `()'
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,972228)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,972228)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,972228)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,972228)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,972228)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,972228)@/usr/share/gjs-1.0/lang.js:204
(bluetooth-wizard:25960): Bluetooth-WARNING **: CreateDevice failed: Timeout was reached
** (bluetooth-wizard:25960): WARNING **: Setting up 'HTC Wildfire S A510e Toby' failed: Timeout was reached
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,942323)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,942323)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,942323)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,942323)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,942323)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,942323)@/usr/share/gjs-1.0/lang.js:204
(bluetooth-wizard:25960): Bluetooth-WARNING **: CreateDevice failed: Timeout was reached
** (bluetooth-wizard:25960): WARNING **: Setting up 'HTC Wildfire S A510e Toby' failed: Timeout was reached
Window Title: 'Bluetooth New Device Setup'; Application Name: 'bluetooth-wizard'; Class: 'Bluetooth-wizard'; Geometry: 729x466+436+393
(bluetooth-wizard:9603): GLib-GIO-WARNING **: Type of return value is incorrect, got `(s)', expected `()'
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,162261)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,162261)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,162261)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,162261)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,162261)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/717/hci0/dev_A8_26_D9_21_7E_3F",null,null,162261)@/usr/share/gjs-1.0/lang.js:204


From /var/log/messages

Apr 27 14:32:14 nexus6 bluetoothd[717]: bluetoothd[717]: Discovery session 0x7f7aafe2ce90 with :1.714 activated
Apr 27 14:32:14 nexus6 bluetoothd[717]: Discovery session 0x7f7aafe2ce90 with :1.714 activated
Apr 27 14:32:28 nexus6 bluetoothd[717]: bluetoothd[717]: Stopping discovery
Apr 27 14:32:28 nexus6 bluetoothd[717]: Stopping discovery
Apr 27 14:33:30 nexus6 bluetoothd[717]: bluetoothd[717]: Agent replied with an error: org.freedesktop.DBus.Error.NoReply, Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Apr 27 14:33:30 nexus6 bluetoothd[717]: Agent replied with an error: org.freedesktop.DBus.Error.NoReply, Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Apr 27 14:33:30 nexus6 dbus-daemon[783]: dbus[783]: [system] Rejected send message, 3 matched rules; type="method_return", sender=":1.714" (uid=1000 pid=9603 comm="bluetooth-wizard ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=717 comm="/usr/sbin/bluetoothd -n ")
Apr 27 14:33:30 nexus6 dbus[783]: [system] Rejected send message, 3 matched rules; type="method_return", sender=":1.714" (uid=1000 pid=9603 comm="bluetooth-wizard ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=717 comm="/usr/sbin/bluetoothd -n ")
Comment 2 Bill C. Riemers 2012-05-14 09:07:10 EDT
I've tried pairing many times to my iPhone.   Once I managed to get it to pair, however since then I had to restore my iPhone from backup.   Normally what happens is pairing fails.  Then the device is list as "paired" but not in a connected state.  It seems about one out of every 10 or so attempts result it a kernel crash that reboots my system.   Nothing seems to be captured in the logs about the crashes.

There is another ticket, with the same problem with a long thread I already made comments on.  This bug is obviously a duplicate.  I can find the other bug number I'll mark it as such.
Comment 3 Bill C. Riemers 2012-05-14 09:08:24 EDT

*** This bug has been marked as a duplicate of bug 733847 ***

Note You need to log in before you can comment on or make changes to this bug.