Bug 813382 - Document how to start services with expired certificates
Document how to start services with expired certificates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Identity_Management_Guide (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deon Ballard
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 11:39 EDT by Dmitri Pal
Modified: 2012-06-26 11:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 11:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-04-17 11:39:02 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2631

We should document how to start the basic IPA services when the SSL certificates have expired so one can run in a degraded mode while the underlying problems are resolved.

In mod_nss set EnforceValidCerts to no and restart httpd

In 389-ds set nsslapd-validate-cert to warn in dse.ldif

Doing these should allow all Apache, Kerberos, named and 389-ds-base to come up so at least users can log in. Client services (e.g. sudo) that require SSL will still fail due to the expired server certificates.
Comment 7 John Skeoch 2012-06-25 19:24:42 EDT
Verified the fix of comment#5 in:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Identity_Management_Guide/troubleshooting-servers-and-replicas.html#expired-certs

Red_Hat_Enterprise_Linux-Identity_Management_Guide-6-en-US-2.2.0-0.9

---

Change the mod_nss configuration for the Apache server to not enforce valid certificates, in the NSSEnforceValidCerts parameter. If this parameter is not already in the file, then add it.
Set the value to off.

[root@ipaserver ~]# vim /etc/httpd/conf.d/nss.conf

NSSEnforceValidCerts off

Note You need to log in before you can comment on or make changes to this bug.