Bug 813407 - pulseaudio keeps crashing
pulseaudio keeps crashing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 12:36 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-05-19 07:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-19 07:43:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
egrep "pulseaudio" /var/log/messages (668.56 KB, text/plain)
2012-04-17 12:36 EDT, Ankur Sinha (FranciscoD)
no flags Details
dmesg | egrep -i "(pulse)|(alsa)|(sound)" (1.34 KB, text/plain)
2012-04-17 12:37 EDT, Ankur Sinha (FranciscoD)
no flags Details
ran pulseaudio -vvvv : log (17.09 KB, text/plain)
2012-04-17 14:45 EDT, Ankur Sinha (FranciscoD)
no flags Details

  None (edit)
Description Ankur Sinha (FranciscoD) 2012-04-17 12:36:16 EDT
Created attachment 578100 [details]
egrep "pulseaudio" /var/log/messages

Description of problem:
pulseaudio randomly crashes. 

Version-Release number of selected component (if applicable):
[root@ankur ~]# rpm -qa | egrep pulse
pulseaudio-module-jack-1.1-8.fc17.x86_64
pulseaudio-1.1-8.fc17.x86_64
pulseaudio-libs-glib2-1.1-8.fc17.x86_64
pulseaudio-libs-1.1-8.fc17.x86_64
pulseaudio-libs-1.1-8.fc17.i686
pulseaudio-module-x11-1.1-8.fc17.x86_64
pulseaudio-module-gconf-1.1-8.fc17.x86_64
pulseaudio-gdm-hooks-1.1-8.fc17.x86_64
pulseaudio-utils-1.1-8.fc17.x86_64
alsa-plugins-pulseaudio-1.0.25-1.fc17.x86_64
pulseaudio-module-bluetooth-1.1-8.fc17.x86_64
pulseaudio-equalizer-2.7-9.fc17.noarch
[root@ankur ~]#

How reproducible:
Randomly.

== More information ==
It randomly crashes. The gnome-sound-applet also disappears. I rerun pulseaudio using pulseaudio --start --log-level=debug. If I refresh gnome shell (alt f2 r), the applet comes back up, but my volume buttons don't work anymore.
Comment 1 Ankur Sinha (FranciscoD) 2012-04-17 12:37:56 EDT
Created attachment 578101 [details]
dmesg | egrep -i "(pulse)|(alsa)|(sound)"
Comment 2 Ankur Sinha (FranciscoD) 2012-04-17 12:44:13 EDT
[ankur@ankur ~]$ pulseaudio --start --log-level=debug
N: [pulseaudio] main.c: User-configured server at {18cb5168dfc36662f0d9bbe900000009}unix:/home/ankur/.pulse/18cb5168dfc36662f0d9bbe900000009-runtime/native, which appears to be local. Probing deeper.
I: [pulseaudio] main.c: Daemon startup successful.

Nothing in ~/.xsession-errors 

Please let me know if you need more info on this Lennart. I'll be more than happy to provide it and help solve this issue. It's too frequent :/

Thanks,
Ankur
Comment 3 Ankur Sinha (FranciscoD) 2012-04-17 13:19:52 EDT
[ankur@ankur dump]$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfbe00000 irq 47
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfb080000 irq 16


[ankur@ankur dump]$ lspci | egrep -i audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
[ankur@ankur dump]$

I've attached gdb to it and am waiting for it to crash to generate a backtrace.
Comment 4 Ankur Sinha (FranciscoD) 2012-04-17 13:29:55 EDT
http://www.alsa-project.org/db/?f=05d19cdbc84c0b3fd70155da67ad86bd034fed56

^ alsa-info.sh output
Comment 5 Ankur Sinha (FranciscoD) 2012-04-17 13:31:34 EDT
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-always-sink.so
Reading symbols from /usr/lib64/pulse-1.1/modules/module-intended-roles.so...Reading symbols from /usr/lib/debug/usr/lib64/pulse-1.1/modules/module-intended-roles.so.debug...done.
done.
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-intended-roles.so
Reading symbols from /usr/lib64/pulse-1.1/modules/module-suspend-on-idle.so...Reading symbols from /usr/lib/debug/usr/lib64/pulse-1.1/modules/module-suspend-on-idle.so.debug...done.
done.
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-suspend-on-idle.so
Reading symbols from /usr/lib64/pulse-1.1/modules/module-position-event-sounds.so...Reading symbols from /usr/lib/debug/usr/lib64/pulse-1.1/modules/module-position-event-sounds.so.debug...done.
done.
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-position-event-sounds.so
Reading symbols from /usr/lib64/pulse-1.1/modules/module-cork-music-on-phone.so...Reading symbols from /usr/lib/debug/usr/lib64/pulse-1.1/modules/module-cork-music-on-phone.so.debug...done.
done.
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-cork-music-on-phone.so
Reading symbols from /usr/lib64/pulse-1.1/modules/module-filter-heuristics.so...Reading symbols from /usr/lib/debug/usr/lib64/pulse-1.1/modules/module-filter-heuristics.so.debug...done.
done.
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-filter-heuristics.so
Reading symbols from /usr/lib64/pulse-1.1/modules/module-filter-apply.so...Reading symbols from /usr/lib/debug/usr/lib64/pulse-1.1/modules/module-filter-apply.so.debug...done.
done.
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-filter-apply.so
Reading symbols from /usr/lib64/pulse-1.1/modules/module-dbus-protocol.so...Reading symbols from /usr/lib/debug/usr/lib64/pulse-1.1/modules/module-dbus-protocol.so.debug...done.
done.
Loaded symbols for /usr/lib64/pulse-1.1/modules/module-dbus-protocol.so
0x000000343aee8f5f in ppoll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>, sigmask=sigmask@entry=0x0) at ../sysdeps/unix/sysv/linux/ppoll.c:58
58                                     _NSIG / 8);
Missing separate debuginfos, use: debuginfo-install celt-0.11.1-3.fc17.x86_64 flac-1.2.1-9.fc17.x86_64 gsm-1.0.13-6.fc17.x86_64 libXau-1.0.6-3.fc17.x86_64 libXext-1.3.1-1.fc17.x86_64 libXi-1.6.0-1.fc17.x86_64 libgcc-4.7.0-2.fc17.x86_64 libogg-1.2.2-4.fc17.x86_64 libstdc++-4.7.0-2.fc17.x86_64 libuuid-2.21.1-1.fc17.x86_64 libvorbis-1.3.3-1.fc17.x86_64 nss-softokn-freebl-3.13.4-2.fc17.x86_64
(gdb) c
Continuing.
[Thread 0x7fa28ade6700 (LWP 22722) exited]
[Thread 0x7fa27ffa5700 (LWP 22732) exited]
[Thread 0x7fa291214780 (LWP 22721) exited]

Program terminated with signal SIGKILL, Killed.
The program no longer exists.
(gdb) thread apply all bt full
(gdb) bt
No stack.
(gdb) thread apply all bt
(gdb)
Comment 6 Ankur Sinha (FranciscoD) 2012-04-17 14:45:56 EDT
Created attachment 578122 [details]
ran pulseaudio -vvvv : log
Comment 7 Ankur Sinha (FranciscoD) 2012-04-17 16:20:42 EDT
Reported upstream. Looks like an issue with power management. Work around:

options snd_hda_intel power_save=0 

in /etc/modprobe.d/sound.conf (create the file)
Comment 8 Ankur Sinha (FranciscoD) 2013-05-19 07:43:10 EDT
Not happening with F19

Note You need to log in before you can comment on or make changes to this bug.