Bug 813432 - Yum ignores virtual provides when glob pattern is used
Yum ignores virtual provides when glob pattern is used
Status: CLOSED DUPLICATE of bug 770137
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 14:43 EDT by Deepak Bhole
Modified: 2014-01-21 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 08:18:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deepak Bhole 2012-04-17 14:43:40 EDT
icedtea-web on Fedora 16 provides java-1.6.0-openjdk-plugin.

On a system with no icedtea-web, 'yum install java-1.6.0-openjdk-plugin' pulls in icedtea-web, as expected.

On the same system however, 'yum install java-1.6.0-openjdk*' does not pull icedtea-web.
Comment 1 Zdeněk Pavlas 2012-04-18 08:18:00 EDT
It's already fixed upstream, but probably not in F16.

commit 7aa4114b18d50addf06a0dfa4a3a5f37985d631f
Author: Zdeněk Pavlas <zpavlas@redhat.com>
Date:   Mon Jan 2 16:32:44 2012 +0100

    do globs on provides in 'yum install'. BZ 770137.
    
    - use searchProvides() as it support globs
    - remove some dead code, reduce branching
    - drop the last user of searchAll()

*** This bug has been marked as a duplicate of bug 770137 ***

Note You need to log in before you can comment on or make changes to this bug.