Bug 813530 - LSB: Starts and stops login and scanning of iSCSI devices Failed on bootup
LSB: Starts and stops login and scanning of iSCSI devices Failed on bootup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike Christie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 15:12 EDT by Rafael Louback Ferraz
Modified: 2012-06-26 12:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 18:32:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smolt profile (3.49 KB, application/octet-stream)
2012-04-17 15:12 EDT, Rafael Louback Ferraz
no flags Details
/var/log/messages (1.22 MB, application/octet-stream)
2012-04-17 21:53 EDT, Rafael Louback Ferraz
no flags Details

  None (edit)
Description Rafael Louback Ferraz 2012-04-17 15:12:37 EDT
Created attachment 578132 [details]
smolt profile

While booting up this service fail.
Comment 1 Mike Christie 2012-04-17 16:54:33 EDT
So are you using iscsi, or are you just reporting that the iscsi service is starting and failing?

What is failing? I did not understand the "stop" part in the bugzilla description?

Could you send the /var/log/messages with the failure?
Comment 2 Rafael Louback Ferraz 2012-04-17 21:52:56 EDT
just reporting that iscsi service is starting and failing. This is slowing down my bootup process.

the start and stop is just the description I get when I run:

systemctl --failed
Comment 3 Rafael Louback Ferraz 2012-04-17 21:53:39 EDT
Created attachment 578205 [details]
/var/log/messages
Comment 4 Mike Christie 2012-04-18 01:02:20 EDT
(In reply to comment #2)
> just reporting that iscsi service is starting and failing. This is slowing down
> my bootup process.
> 

How much is slowing down boot? Minutes?

There was a bug where the iscsi init script was waiting a long time for the network to come up even if you were not using iscsi. It was fixed in
https://admin.fedoraproject.org/updates/iscsi-initiator-utils-6.2.0.872-17.fc16
bz:
https://bugzilla.redhat.com/show_bug.cgi?id=789683

Are you using any virt stuff? If not then you can just disable iscsi. Vrit brings in iscsi and needs it started, so it is getting installed by default on many systems.
Comment 5 Rafael Louback Ferraz 2012-04-18 18:11:51 EDT
not minutes, but its a 10~15 seconds

Im not using virt, How can I disable iscsi? This isnt supposed to be done automatically by the system?
Comment 6 Mike Christie 2012-04-19 17:45:38 EDT
(In reply to comment #5)
> not minutes, but its a 10~15 seconds
> 
> Im not using virt, How can I disable iscsi? This isnt supposed to be done
> automatically by the system?

 chkconfig --del iscsi
 chkconfig --del iscsid


It is not getting done auotmatically by the system because something is installing it. We have seen this in the past when some virt tools are installed (they bring in iscsi and they need iscsi to be run).
Comment 7 Rafael Louback Ferraz 2012-04-20 18:32:54 EDT
today, after some fedora updates. this problem was fixed. Thanks for the help

Note You need to log in before you can comment on or make changes to this bug.