Bug 813541 - RFE - Enable application status filtering in web-ui
RFE - Enable application status filtering in web-ui
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiri Tomasek
wes hayutin
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 15:43 EDT by James Laska
Modified: 2013-09-02 03:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Filtering was enabled on application states but the list of applications in the cloud resource zone was not allowing filtering based on status. A drop-down list was available but disabled. This enhancement displays the list of applications based on their status ("running", "failed", "vanished", "stopped") which now allows the application status' to filter in a UI.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:04:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Applications screenshot.png (135.95 KB, image/png)
2012-04-17 15:43 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2012-04-17 15:43:49 EDT
Created attachment 578134 [details]
Applications screenshot.png

Description of problem:

The list of applications in a cloud resource zone does not allow filtering based on status (https://[[CONDUCTOR]]/conductor/pools/2).  A drop-down list is available, but disabled.  It would be helpful to filter the list of applications based on their status ("running", "failed", "vanished", "stopped")
 
 * This filter is available when listing the Cloud Resource Zones (https://[CONDUCTOR]/conductor/pools?details_tab=pools&only_tab=true&view=filter)
 * A similar filter is available when viewing the instances (https://[CONDUCTOR]/conductor/pools?details_tab=instances&only_tab=true&view=filter)

Version-Release number of selected component (if applicable):
 * aeolus-conductor-0.8.7-1.el6.src.rpm
 * aeolus-configure-2.5.2-1.el6.src.rpm
 * rubygem-aeolus-cli-0.3.1-1.el6.src.rpm
 * rubygem-aeolus-image-0.3.0-12.el6.src.rpm

Steps to Reproduce:
1. Ensure several applications are launched to a particular cloud resource zone
2. From Monitor, select a cloud resource zone
3. Choose the list-view (not the card view)
4. Attempt to filter applications by status
  
Actual results:

 * The status filter is disable, and I'm unable to make a selection

Expected results:

 * I should be able to filter the list of applications by selecting "Stopped Applications", or "Failed applications"

Additional info:
Comment 1 wes hayutin 2012-04-17 15:50:47 EDT
So.. after drawing a blank on this.. I think application filtering was disabled because applications can be in a "mixed" state..  where one instance is up and one is down, and one is vanished

so..  whats the state of that application..
Comment 2 wes hayutin 2012-04-17 15:51:31 EDT
Angus, I think this is probably not a bug.. ur comments please
Comment 3 Angus Thomas 2012-04-17 16:10:02 EDT
We have some preparatory work to do, in terms of the way that we report the possible states of multi-instance applications. Once that is done, we will enable filtering on application state.
Comment 4 Jiri Tomasek 2012-09-03 07:50:31 EDT
Pull request: https://github.com/aeolusproject/conductor/pull/32
Comment 5 Jiri Tomasek 2012-09-04 03:46:39 EDT
patch pushed to master(d6b64f1) and 1.1(ef230c5)
Comment 6 Steve Linabery 2012-09-07 17:53:06 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 8 Aziza Karol 2012-09-25 09:08:02 EDT
Application status filtering in web-ui is enabled now.

verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 10 errata-xmlrpc 2012-12-04 10:04:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.