Bug 813546 - Livecd-creator will not create updated Livecds
Livecd-creator will not create updated Livecds
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
16
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 16:10 EDT by Ben Williams
Modified: 2012-05-29 16:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 16:27:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Williams 2012-04-17 16:10:48 EDT
Description of problem:

creating a updated livecd 
Version-Release number of selected component (if applicable):


How reproducible:
on both 32 and 64 bit F16


Steps to Reproduce:
1.yum install livecd-tools
2.yum install fedora-kickstarts
3.livecd-creator -c /usr/share/spinkickstarts/fedora-livecd-desktop.ks --fslabel=F16-Live-Desk-<arch>-<date>
<arch>=i686,x86_64   <date>=yyyymmdd
  
Actual results:

Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 210, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 194, in main
    creator.configure()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 724, in configure
    self._create_bootconfig()
  File "/usr/lib/python2.7/site-packages/imgcreate/live.py", line 242, in _create_bootconfig
    self._generate_efiboot(self.__ensure_isodir())
  File "/usr/lib/python2.7/site-packages/imgcreate/live.py", line 235, in _generate_efiboot
    isodir + "/isolinux/efiboot.img"])
  File "/usr/lib64/python2.7/subprocess.py", line 493, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1228, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Expected results:

to create the iso 
Additional info:
Comment 1 Brian Lane 2012-04-17 16:19:15 EDT
Is lorax installed? This looks like mkefiboot (provided by lorax) isn't installed. It should get pulled in automatically.
Comment 2 Ben Williams 2012-04-17 16:30:02 EDT
yes lorax is installed lorax-16.4.7-2.fc16.x86_64
Comment 3 Ben Williams 2012-04-17 16:36:15 EDT
yes lorax is installed lorax-16.4.7-2.fc16.x86_64
Comment 4 Brian Lane 2012-04-17 16:56:32 EDT
ah! 16.4.8-2 isn't stable yet. Could you give it a try and leave feedback here:

https://admin.fedoraproject.org/updates/FEDORA-2012-3400/lorax-16.4.8-2.fc16
Comment 5 Ben Williams 2012-04-18 15:34:25 EDT
It appears the new lorax rpm fixes the issues i was  seeing 
Thank you for the quick reply
Comment 6 Valent Turkovic 2012-05-03 08:25:32 EDT
Me too on this bug ;)

I had same issue, but didn't have lorax installed. Is that a separate bug? Maybe livecd-creator package doesn't have it as a dependency?


# yum install lorax
Dependencies Resolved

==================================================================================
 Package                          Arch                      Version                           Repository                  Size
==================================================================================
Updating:
 lorax                            x86_64                    16.4.8-2.fc16                     updates                     92 k
Installing for dependencies:
 hfsplus-tools                    x86_64                    332.14-12.fc15                    fedora                     118 k
Comment 7 Valent Turkovic 2012-05-03 08:26:58 EDT
Sorry, my bad, I missed "updating" part. It looks it was installed, just not up to date.
Comment 8 Valent Turkovic 2012-05-03 09:59:53 EDT
I got iso buils and it boots without errors now. Thank you very much!
Comment 9 Valent Turkovic 2012-05-28 03:58:44 EDT
I'm getting ISO images to build now, but they are broken! None of images boot to GUI, only first part starts to show but I couldn't get not one to get to login screen.

Something is very badly broken.
Comment 10 Brian Lane 2012-05-29 16:27:17 EDT
If you have specific problems, please open a new bug with details. This is related to not having lorax installed.

Note You need to log in before you can comment on or make changes to this bug.