Bug 813574 - lab controller daemons should use python-daemon for daemonization
lab controller daemons should use python-daemon for daemonization
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.8
Unspecified Unspecified
low Severity unspecified (vote)
: 0.11
: ---
Assigned To: Dan Callaghan
ImplementationQuality
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 18:45 EDT by Dan Callaghan
Modified: 2013-01-16 23:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-16 23:34:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-04-17 18:45:51 EDT
For consistency with beakerd, we should use python-daemon (instead of kobo.process.daemonize) in the lab controller daemons as well.

See also bug 812687.
Comment 1 Dan Callaghan 2012-11-13 23:09:17 EST
James wrote a patch for this: http://gerrit.beaker-project.org/#/c/1399/

I will just need to double-check that everything works nicely with gevent.
Comment 4 Raymond Mancy 2013-01-03 23:25:18 EST
The main problem that I can find with this is that we daemonise before we try to login to the scheduler, and if the login fails we do not kill the process.

If time permits I think we should change this.
Comment 5 Dan Callaghan 2013-01-03 23:30:29 EST
(In reply to comment #4)
> The main problem that I can find with this is that we daemonise before we
> try to login to the scheduler, and if the login fails we do not kill the
> process.
> 
> If time permits I think we should change this.

I've already tried to fix it, a long time ago:

http://gerrit.beaker-project.org/824

but it's not possible due to kobo bug 753006. I believe this patch for switching to python-daemon hasn't made the situation any worse than it was before.
Comment 6 Raymond Mancy 2013-01-03 23:34:44 EST
Sorry I forgot about that old bug. And no this doesn't make it anyworse than before.
Comment 7 Dan Callaghan 2013-01-16 23:34:22 EST
Beaker 0.11.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.