Bug 813647 - Stacktrace when closing a bug
Stacktrace when closing a bug
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
: 813927 (view as bug list)
Depends On:
Blocks: BZ42
  Show dependency treegraph
 
Reported: 2012-04-18 02:22 EDT by Krzysztof Daniel
Modified: 2014-10-12 18:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.2.0-0.b26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 01:00:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-04-18 02:22:04 EDT
I have observed this behaviour when using Eclipse Mylyn.

(1) Install eclipse and eclipse-mylyn-*
(2) Open any bug that is on QA state.
(3) Try to move it to 'CLOSED'
(4) Error appears that indicates bugzilla error:

(Eclipse says) Error may result when QAContact field not enabled.
((Embedded browser shows)
 Undef to trick_taint at Bugzilla/Util.pm line 67
       Bugzilla::Util::trick_taint('undef') called at Bugzilla/Bug.pm line
 4525
       Bugzilla::Bug::LogActivityEntry(766608, 'cf_last_closed', 'undef',
 '2012-04-17 07:22:48', 324097, '2012-04-17 07:22:48') called
 at ./extensions/RedHat/Extension.pm line 992
 
 ugzilla::Extension::RedHat::bug_end_of_update('Bugzilla::Extension::RedHat=HASH(0xa930c0)', 'HASH(0xe243760)') called at Bugzilla/Hook.pm line 33
       Bugzilla::Hook::process('bug_end_of_update', 'HASH(0xe243760)') called
 at Bugzilla/Bug.pm line 1157
       Bugzilla::Bug::update('Bugzilla::Bug=HASH(0xddf60d0)') called
 at /var/www/html/bugzilla/process_bug.cgi line 498
Comment 1 Simon Green 2012-04-18 07:13:45 EDT
I noticed this a few hours before you filed the bug. It applies to all cases where you close a bug for the first time. Will get it fixed tomorrow hopefully.
Comment 2 Simon Green 2012-04-18 17:45:34 EDT
*** Bug 813927 has been marked as a duplicate of this bug. ***
Comment 3 Simon Green 2012-04-20 01:00:39 EDT
Fix will be visible in the next update

  -- simon

Note You need to log in before you can comment on or make changes to this bug.