This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 813648 - gnome-shell shows blank windows on hardware lacking NPOT textures
gnome-shell shows blank windows on hardware lacking NPOT textures
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cogl (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
AcceptedBlocker
: Regression
: 797025 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-04-18 02:23 EDT by Ben Skeggs
Modified: 2012-05-16 12:34 EDT (History)
10 users (show)

See Also:
Fixed In Version: mutter-3.4.1-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 01:25:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Skeggs 2012-04-18 02:23:17 EDT
Description of problem:

GeForce FX (and below) hardware has no support for full GL_ARB_texture_non_power_of_two.  gnome-shell/clutter/cogl (whatever's responsible) used to handle things correctly just using GL_ARB_texture_rectangle, but apparently this got broken some time between F16 and F17.

Version-Release number of selected component (if applicable):

How reproducible:
Always, if you have the "right" hardware.

Steps to Reproduce:
1. Have a GeForce FX or below GPU
2. Try to use gnome-shell in F17

or

1. Be using F17
2. gnome-shell --cogl-debug=disable-npot-textures --replace
  
Actual results:
Windows don't have their contents.

Expected results:
Windows show their contents.

Additional info:
Comment 1 Dave Airlie 2012-05-02 05:22:52 EDT
http://git.gnome.org/browse/cogl/tree/cogl/cogl-primitives.c#n556

is where we saw this going wrong before.

cogl would end up picking the 0 layer which was the shadow not the first layer which was the window contents.
Comment 2 Adam Jackson 2012-05-02 13:39:15 EDT
#clutter suggests this bit of mutter might be apropos:

http://git.gnome.org/browse/mutter/commit/?id=a22859a64a6

Testing now.
Comment 3 Adam Jackson 2012-05-03 14:58:22 EDT
That, plus this:

http://git.gnome.org/browse/mutter/commit/?id=ed358c8f4b1200

makes 'gnome-shell --cogl-debug=disable-npot-textures --replace' work again (tested on Intel GM45 GPU).
Comment 4 Adam Williamson 2012-05-09 11:09:02 EDT
Proposing as a blocker, as this is another case of Shell not working right on quite a lot of hardware. Possible actions here are either to fix the bug (but the patches may not be entirely safe at this late stage) or to blacklist all NVIDIAs up to nv3x. We could of course then ship a post-release mutter update to fix the bug, and a gnome-session update which depended on that version of mutter and withdrew the blacklisting.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2012-05-09 14:44:57 EDT
Opinions on which of the two options is preferable are desired. ;)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Ben Skeggs 2012-05-09 21:02:21 EDT
If you're going to go with a blacklisting option, I'd blacklist on any GL not reporting support for GL_ARB_texture_non_power_of_two.  This would automagically blacklist any card that'll hit the issue (<=NV3x in nouveau's case).

I really prefer the actual problem being fixed though :)
Comment 7 Fedora Update System 2012-05-10 11:40:02 EDT
mutter-3.4.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mutter-3.4.1-3.fc17
Comment 8 Stephen Sheldon 2012-05-10 12:56:16 EDT
I tried the mutter build in Comment 7 with my NV34 FX5200 card, and window contents are now displayed correctly.  I still have the text problems I reported in BZ 745202, originally against FC16.
Comment 9 Fedora Update System 2012-05-10 16:38:53 EDT
Package mutter-3.4.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mutter-3.4.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7614/mutter-3.4.1-3.fc17
then log in and leave karma (feedback).
Comment 10 Adam Williamson 2012-05-10 18:00:29 EDT
stephen: I think we'll keep NV34 blacklisted for the text issues.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Adam Williamson 2012-05-10 23:04:01 EDT
I'm +1 blocker on this one. I think it's worth taking the good fix for it rather than blacklisting.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2012-05-11 20:48:12 EDT
Discussed at the 2012-05-11 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-05-11/f17-final-blocker-review-meeting-5.2012-05-11-17.04.html . This was accepted as NTH. There was not a clear consensus on whether it should be a blocker bug, so that status is left open for further review (though the NTH acceptance means the fix will be pulled anyway).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Tim Flink 2012-05-14 14:44:51 EDT
Discussed at the 2012-05-14 mini blocker review meeting. Accepted as a blocker for Fedora 17 final due to violation of the following Fedora 17 alpha release criterion [1] for specific graphics cards:

"Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied"
Comment 14 Adam Williamson 2012-05-14 22:22:31 EDT
Having this as NTH *and* blocker is overkill...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Fedora Update System 2012-05-15 01:25:43 EDT
mutter-3.4.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Adam Jackson 2012-05-16 12:34:59 EDT
*** Bug 797025 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.