Bug 813662 - [abrt] subdownloader-2.0.14-2.fc15: main.py:461:onViewOnlineInfo:AttributeError: 'NoneType' object has no attribute 'data'
[abrt] subdownloader-2.0.14-2.fc15: main.py:461:onViewOnlineInfo:AttributeErr...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: subdownloader (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Klepek
Fedora Extras Quality Assurance
abrt_hash:9a1e9d93d5b995f44318f8b7719...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 03:17 EDT by Răzvan Sandu
Modified: 2012-11-29 01:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 06:41:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2012-04-18 03:17:42 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        python /usr/bin/subdownloader
executable:     /usr/bin/subdownloader
kernel:         3.3.1-5.fc16.x86_64
reason:         main.py:461:onViewOnlineInfo:AttributeError: 'NoneType' object has no attribute 'data'
time:           Mi 18 apr 2012 05:06:38 +0300
uid:            500
username:       rsandu

backtrace:
:main.py:461:onViewOnlineInfo:AttributeError: 'NoneType' object has no attribute 'data'
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/subdownloader/gui/main.py", line 461, in onViewOnlineInfo
:    if type(treeItem.data) == VideoFile:
:AttributeError: 'NoneType' object has no attribute 'data'
:
:Local variables in innermost frame:
:index: <PyQt4.QtCore.QModelIndex object at 0x17e83d0>
:self: <gui.main.Main object at 0x177c710>
:listview: <PyQt4.QtGui.QTreeView object at 0x1805dd0>
:treeItem: None

smolt_data:
:
:
:General
:=================================
:UUID: 64a8eef6-4329-4517-9b38-bb9ed807a4c9
:OS: Fedora release 16 (Verne)
:Default run level: 5
:Language: ro_RO.utf8
:Platform: x86_64
:BogoMIPS: 3323.56
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     T5450  @ 1.66GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 1667
:System Memory: 2002
:System Swap: 4096
:Vendor: Dell Inc.
:System: Inspiron 1520 
:Form factor: Portable
:Kernel: 3.3.1-5.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10752:4136:497) pci, None, HOST/PCI, Mobile PM965/GM965/GL960 Memory Controller Hub
:(32902:10753:4136:497) pci, pcieport, PCI/PCI, Mobile PM965/GM965/GL960 PCI Express Root Port
:(32902:10302:4136:497) pci, i801_smbus, SERIAL, 82801H (ICH8 Family) SMBus Controller
:(32902:10280:4136:497) pci, ata_piix, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller
:(32902:10320:4136:497) pci, ata_piix, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller
:(32902:10261:4136:497) pci, None, PCI/ISA, 82801HEM (ICH8M) LPC Interface Controller
:(5348:17169:4136:7) pci, b43-pci-bridge, NETWORK, Wireless 1390 WLAN Mini-Card
:(32902:9288:4136:497) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10289:4136:497) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #2
:(32902:10288:4136:497) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #1
:(32902:10290:4136:497) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #3
:(4480:1426:4136:497) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(4480:2130:4136:497) pci, r852, BASE, xD-Picture Card Controller
:(4480:2098:4136:497) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(32902:10298:4136:497) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #2
:(5348:5900:4136:497) pci, b44, ETHERNET, BCM4401-B0 100Base-TX
:(32902:10309:4136:497) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 4
:(32902:10303:4136:497) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10305:4136:497) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 2
:(32902:10315:4136:497) pci, snd_hda_intel, MULTIMEDIA, 82801H (ICH8 Family) HD Audio Controller
:(32902:10292:4136:497) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #4
:(32902:10293:4136:497) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #5
:(4318:1063:4136:497) pci, nouveau, VIDEO, G86 [GeForce 8400M GS]
:(32902:10294:4136:497) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #1
:(4480:2082:4136:497) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 37710761 13105792 11217728 9445376 9003903 9003903
:/dev/sda1 /boot ext4 4096 4096 261467 230019 216912 65536 65243 65243
:
Comment 1 Jan Klepek 2012-08-26 10:03:43 EDT
Hi,

Can you please write how to reproduce this issue? I'm not able to reproduce it
Comment 2 Fedora Update System 2012-11-19 03:25:40 EST
subdownloader-2.0.18-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/subdownloader-2.0.18-1.fc17
Comment 3 Fedora Update System 2012-11-19 03:26:55 EST
subdownloader-2.0.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/subdownloader-2.0.18-1.fc18
Comment 4 Fedora Update System 2012-11-19 14:35:18 EST
Package subdownloader-2.0.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing subdownloader-2.0.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18508/subdownloader-2.0.18-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-11-28 06:41:37 EST
subdownloader-2.0.18-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-11-29 01:33:52 EST
subdownloader-2.0.18-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.