Bug 81367 - can't print from Raw Hide mozilla
can't print from Raw Hide mozilla
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-08 11:03 EST by Jonathan Kamens
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-23 11:44:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-01-08 11:03:40 EST
When I try to print from the mozilla with everything current from Raw Hide, it
hangs after putting up the "Preparing..." dialog.

When I strace mozilla-bin before doing the print, the strace says that it vforks
and then tries to write to the child process, and the write blocks.  It appears
as if the child process isn't actually doing anything after the vfork (unless
strace itself is confused):

1203  pipe([24, 25])                    = 0
1203  vfork()                           = 1224
1203  close(24)                         = 0
1203  write(23, "neto 0 -684 rlineto -504 0 rline"..., 1688) = 1688
1203  _llseek(23, 0, [0], SEEK_SET)     = 0
1203  read(23, "%!PS-Adobe-3.0\n%%BoundingBox: 18"..., 4096) = 4096
1203  fstat64(25, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
1203  old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x40e9a000
1203  read(23, "ont setfont } bind def\n/F7\n    /"..., 4096) = 4096
1203  write(25, "%!PS-Adobe-3.0\n%%BoundingBox: 18"..., 4096) = 4096
1203  read(23, "2    /b\n16#0063    /c\n16#0064   "..., 4096) = 4096
1203  write(25, "ont setfont } bind def\n/F7\n    /"..., 4096) = ? ERESTARTSYS
(To be restarted)

The end of the last line above was printed after I killed the child process,
after waiting for quite a while for it to do something.

This happens repeatedly, i.e., it wasn't a fluke.
Comment 1 Christopher Blizzard 2003-01-08 13:45:14 EST
Might be lpr having issues?
Comment 2 Tim Waugh 2003-01-08 13:47:25 EST
Well, does saving it to a file and doing 'lpr <mozilla.ps' work?
Comment 3 Jonathan Kamens 2003-01-08 16:47:59 EST
Yes, printing to a file and then feeding the file into lpr does work.
Comment 4 Jonathan Kamens 2003-01-08 16:53:20 EST
Wait, I'm going to take that back.  It works erratically.  Sometimes it prints,
sometimes it doesn't.  But it never hangs -- when it doesn't print, it simply
exits with no error but nothing comes out of the printer.
Comment 5 Tim Waugh 2003-01-09 08:24:54 EST
'Working erratically' seems to be a different bug.

At the time of the mozilla hang, what does 'ps axf' show about its child
processes?  By the way, strace doesn't follow vfork by default.
Comment 6 Jonathan Kamens 2003-01-09 09:53:56 EST
I know strace doesn't do vfork by default; I specified "-f -F" when I ran it to
produce the output shown above.

Here's what the mozilla process tree looks like after it hangs:

> ps auxw | grep mozilla-bin
jik      12895  0.0  0.0     0    0 pts/0    Z    09:45   0:00 [mozilla-bin
<defunct>]
jik      12889  4.5  5.2 49596 26900 pts/0   S    09:45   0:04
/usr/lib/mozilla-1.2.1/mozilla-bin
jik      12909  0.0  5.2 49592 26896 pts/0   S    09:47   0:00
/usr/lib/mozilla-1.2.1/mozilla-bin
> pstree -p 12889
mozilla-bin(12889)-+-mozilla-bin(12895)
                   `-mozilla-bin(12909)
Comment 7 Tim Waugh 2003-01-17 07:41:06 EST
Are you just running 'some' rawhide packages, or is this an updated Phoebe
installation?
Comment 8 Jonathan Kamens 2003-01-17 07:46:50 EST
When I reported this bug, I was completely up-to-date with Raw Hide.  Since then
I've had to back down some Raw Hide packages because of incompatibilities with
vmware.
Comment 9 Tim Waugh 2003-01-17 07:52:00 EST
It occurs to me I never asked if this is cups or LPRng (oops!).
Comment 10 Jonathan Kamens 2003-01-17 07:56:32 EST
It occurs to me that I never specified :-).
CUPS.
Comment 11 Christopher Blizzard 2003-02-21 20:37:25 EST
Is this still happening?
Comment 12 Jonathan Kamens 2003-02-22 18:23:11 EST
I haven't seen this recently.
Comment 13 Christopher Blizzard 2003-02-23 11:44:28 EST
Marking WORKSFORME based on reporter comments.

Note You need to log in before you can comment on or make changes to this bug.