Bug 813686 - Some new kind of autoscroll is ON by default
Some new kind of autoscroll is ON by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 04:38 EDT by Zdenek Kabelac
Modified: 2013-01-13 08:00 EST (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-drv-synaptics-1.6.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 00:16:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2012-04-18 04:38:54 EDT
Description of problem:

With update to version: xorg-x11-drv-synaptics-1.5.99.903-1.fc18
my firefox/chrome started to behave quite crazy - since some new kind of autoscroll started to work - i.e. when I slide my finger it starts to autoscroll page downwards or upwards without any further activity on my side - something like on various  X-pad like device.

However this feature is highly annoying when I work with laptop - i.e when I pres CTRL fonts are being resized, the time period for 'short' or 'long term' scroll are also fuzzy - in general I'm considering this feature in current state as usable only for some 'hard core' 'pad' lovers. For a programmer I'd prefer default behavior from xorg-x11-drv-synaptics-1.5.99.902-1.fc18 - as I've downgraded to this version:

Here is my T61 settings with 1.5.99.902-1

$ synclient
Parameter settings:
    LeftEdge                = 1752
    RightEdge               = 5192
    TopEdge                 = 1620
    BottomEdge              = 4236
    FingerLow               = 25
    FingerHigh              = 30
    FingerPress             = 256
    MaxTapTime              = 180
    MaxTapMove              = 221
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    FastTaps                = 0
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 67
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 100
    HorizScrollDelta        = 100
    VertEdgeScroll          = 1
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 0
    HorizTwoFingerScroll    = 0
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0398089
    TrackstickSpeed         = 40
    EdgeMotionMinZ          = 30
    EdgeMotionMaxZ          = 160
    EdgeMotionMinSpeed      = 1
    EdgeMotionMaxSpeed      = 401
    EdgeMotionUseAlways     = 0
    TouchpadOff             = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 0
    RBCornerButton          = 0
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 0
    TapButton2              = 0
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 1
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice         = 1
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 25
    VertHysteresis          = 25
    ClickPad                = 0




Version-Release number of selected component (if applicable):

xorg-x11-drv-synaptics-1.5.99.903-1.fc18

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrew Hutchings 2012-04-18 09:18:23 EDT
same on my Lenovo X220.  It is almost as if the scroll now has a very long deceleration phase (sometimes lasting a minute).  Tried both edge and 2-finger modes, both have the same effect.  Had to disable scrolling for now.
Comment 2 Kevin Fenzi 2012-04-18 21:15:36 EDT
Seeing this here also on a T510. 

I didn't realize what was causing it at first. ;(
Comment 3 Fedora Update System 2012-04-18 23:33:39 EDT
xorg-x11-drv-synaptics-1.5.99.903-2.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-2.20120419git11d892964.fc17
Comment 4 Andrew Hutchings 2012-04-19 00:45:02 EDT
awesome, that fixes it for me :)
Comment 5 Fedora Update System 2012-04-19 22:26:17 EDT
Package xorg-x11-drv-synaptics-1.5.99.903-2.20120419git11d892964.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.5.99.903-2.20120419git11d892964.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6234/xorg-x11-drv-synaptics-1.5.99.903-2.20120419git11d892964.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-22 19:15:18 EDT
xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-6229/xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc17
Comment 7 Fedora Update System 2012-04-24 01:54:12 EDT
xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.903-4.20120419git11d892964.fc17
Comment 8 Zdenek Kabelac 2012-04-24 08:30:27 EDT
xorg-x11-drv-synaptics-1.5.99.903-3.20120419git11d892964.fc18.x86_64

works for me.
Comment 9 Fedora Update System 2012-04-26 19:42:10 EDT
xorg-x11-drv-synaptics-1.5.99.904-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.5.99.904-1.fc17
Comment 10 Fedora Update System 2012-05-02 18:49:07 EDT
xorg-x11-drv-synaptics-1.6.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.0-1.fc17
Comment 11 Zdenek Kabelac 2012-05-03 05:40:13 EDT
I need to reopen this BZ again - since this  'X-pad' behavior is back on my rawhide with: xorg-x11-drv-synaptics-1.5.99.904-1.fc18.x86_64

If some developer of synaptics like this - let's make it configurable via some GUI - I find it annoying to push such thing as default for laptops (whenever I scroll in firefox and start to type something with Ctrl key - I usually get the resized page)

While current way of dynamic scroll is less annoying then original with  1.5.99.903-1.fc18 - it's still seen as a 'way back' -  laptop is not X-pad  device.
Comment 12 Andrew Hutchings 2012-05-03 06:06:44 EDT
I'm pretty sure looking at the patch and commit msg that the original problem was entirely accidental (a basic math problem with the deceleration calculations IIRC).  So please don't blame the developers for pushing a new behaviour patterns, they do an awesome job :)

Note that I don't see the behaviour in 904-1 with F17 on my X220.
Comment 13 Zdenek Kabelac 2012-05-03 08:27:23 EDT
Well I hope  Xorg developers are not suffering from GNOME disease - where users are not even allowed to easily change the color of title bar.

As I said - I don't mind for this behavior on tablets - but on my laptop touchpad I find it quite annoying to concentrate on the amount of power used for scrolling things to avoid kinetics effect.

There needs to be a clear easy way how to keep this thing disabled.
(And I think 'Off' should be the default - but at least Changelog of the package
should mention something about this new feature.)

Anyway reading the manpage for synaptic driver and reading all the options I've found:

Option "CoastingSpeed" "float"
   Your  finger needs to produce this many scrolls per second in order
   to start coasting.  The default is 20 which should prevent you from
   starting  coasting unintentionally.  0 disables coasting. Property:
   "Synaptics Coasting Speed"

So running:

synclient  CoastingSpeed=0
(By default it's been 20 in my case)

disables it - but I think this quite unprofessional to let user whit each update watch out how they have to configure their config files, to get some stable behavior (unless GNOME path is now seen as a way to the future) 

What makes me actually interesting now is - if you do not see it with 904-1 - maybe it's now being actually set by some gnome config deamon ??
(I'll try to investigate when I'll have time)
Comment 14 Fedora Update System 2012-05-03 12:01:31 EDT
Package xorg-x11-drv-synaptics-1.6.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.6.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7215/xorg-x11-drv-synaptics-1.6.0-1.fc17
then log in and leave karma (feedback).
Comment 15 Peter Hutterer 2012-05-04 03:02:20 EDT
I'm just gonna ignore the flamebait, but please assume good intentions.

Different folks like different behaviours. Automatic coasting based on scrolling friction was enabled in synaptics 1.3 in September 2010 (Fedora 14). That explains why you couldn't find anything in the changelogs.

https://fedoraproject.org/wiki/Input_device_configuration explains how to set configuration options.
 
> What makes me actually interesting now is - if you do not see it with 904-1 -
> maybe it's now being actually set by some gnome config deamon ??
> (I'll try to investigate when I'll have time)

The previous release candidates had a bug where the scrolling could continue forever, that was the bug that was fixed. gnome does not change coasting behaviour.
Comment 16 Zdenek Kabelac 2012-05-04 08:00:55 EDT
Ok - so if it was there for 2 years - then something must have changed - when I reported bug for the first time - which has been fixed with scrolling bug.
But while -3 seemed to work fine - the version 904-1 I've again experienced unpleasant side effect of getting resized FF window while using touchpad scroll.

While I'm mostly sure I do scroll pages the same way for many years, the frequency of unexpected resizes (pressed Ctrl while some coasting was still in effect) went up. So was there still something updated between 1.6 and 1.5 version in this area?
Comment 17 Zdenek Kabelac 2012-05-04 08:23:40 EDT
I've just updated to:

xorg-x11-drv-synaptics-1.6.0-1.fc18.x86_64

And still see the same unwanted behavior.

Are there any other usable values then 0 or 20 for CoastingSpeed?
It seems whatever value for [1-20] I set there, I get the same behavior.
I simply do not see any change in reaction on scroll in firefox.

So I start to suspect that the math behind the usage of CoastingSpeed has changed, when I started to notice problems...

My laptop is  T61 with SynPS/2.

As a positive sign - I'd say that setting CoastingFriction=200  (my default was 50) makes this feature a bit more 'useful' since with this value I do not get resize and changes of gnome desktops......
Comment 18 Andrew Hutchings 2012-05-04 14:21:53 EDT
Ah, I see it now (I didn't realise it had been so long since I restarted X), a small deceleration on rapid scrolling.  I quite like it personally.

It would probably be a new bug report if this behaviour is not what you would like (since this one is one the endless coasting).
Comment 19 Fedora Update System 2012-05-07 00:16:12 EDT
xorg-x11-drv-synaptics-1.6.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-05-10 22:39:17 EDT
xorg-x11-drv-synaptics-1.6.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.1-1.fc17
Comment 21 Peter Hutterer 2012-05-10 22:44:51 EDT
1.6.1 fixes the issue. the coasting trigger was wrong, so all scroll events started it. plus, setting it to more than 20 with synclient didn't actually do anything. Trigger is fixed, synclient allows up to 255 now. so you can at least configure it, the default behaviour stays the same though.
Comment 22 Fedora Update System 2012-06-06 22:39:37 EDT
xorg-x11-drv-synaptics-1.6.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.