Bug 813693 - (katello-foreman) RFE: Integrate Foreman
RFE: Integrate Foreman
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: 6.0
Assigned To: Lukas Zapletal
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 04:42 EDT by Lukas Zapletal
Modified: 2014-09-18 11:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:44:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-04-18 04:42:51 EDT
This is a feature tracker bug that shows progress of foreman integration and also link other feature requests on the foreman side that needs to be done to fully integrate it.
Comment 1 Lukas Zapletal 2012-04-18 04:46:11 EDT
To fully integrate Katello, Foreman API must be accessible with oauth. Once oauth is enabled in the Foreman configuration and secret and token is given, Foreman should authenticate all requests with valid oauth and automatically authorize those requests as "admin". Separate role can be used for this, but all permission must be given. Katello is expected to be able to do anything.

http://theforeman.org/issues/1576
Comment 2 Lukas Zapletal 2012-04-18 04:48:54 EDT
Katello and Foreman is expected to run on the same server. Since default ports HTTP and HTTPS are already used by Katello and its backend engines, Foreman will need to be working with a prefix. Since Anaconda installer have problems with kickstarting from different ports than standard 80 and 443, this configuration variable will be likely necessary to support Katello/Foreman kickstarting.

http://theforeman.org/issues/1577
Comment 3 Lukas Zapletal 2012-04-18 07:36:12 EDT
Katello is multi-tenant system and it supports organizations and environments. Typically, every resource belongs to an organization and a environment. Foreman already supports environments for hosts (I am not sure if they can be assigned across whole Foreman) and we could use them for this purpose. It would be good idea to implement also organizations, so we would have direct mapping between Katello and Foreman.

From the history, Candlepin did support only organizations (called owners there), Pulp does not support either orgs or envs. In Candlepin it was tricky to work without environments and some time ago we have decided to implement environments in Candlepin. In Pulp there is no support for them, so resources have very long and ugly names like:

Organization_Name-environment_name-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_5_Server_RPMs_x86_64_5Server

We would need to do the same for Foreman. Each resource (like operating system, installation media etc) would need to have similar name. But with organizations and environments extended for all resources (or at least installation media, operating systems and templates) we could only use the Candlepin product name which is shorter (Red_Hat_Enterprise...).

From our experiences I think it would be better to implement this into the Foreman than to use the string-concatenating approach. Please consider this feature.

http://theforeman.org/issues/1578
Comment 4 Bryan Kearney 2014-01-21 14:07:45 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.

Note You need to log in before you can comment on or make changes to this bug.