Bug 813732 - NFS halts when accessing several files
NFS halts when accessing several files
Status: CLOSED DUPLICATE of bug 811138
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 06:37 EDT by Andreas-Johann Ulvestad
Modified: 2012-04-18 08:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 08:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas-Johann Ulvestad 2012-04-18 06:37:58 EDT
Description of problem:
When accessing several files at the same time (eg Evolution), NFS halts and a kernel message is printed on all terminals.

When using evolution, this usually happens each 15 minutes.

The clients are Fedora 16 i686 connected to a RHEL 6.2 NFS server. Mount options are: rsize=8192,wsize=8192. We used to have mount option 'tcp' as well, but that lead to constant hickups. mtab lists:
{{SERVERIP}}:/home/ /home nfs4 rw,relatime,vers=4,rsize=8192,wsize=8192,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr={{CLIENTIP SAME SUBNET}},minorversion=0,local_lock=none,addr={{SERVERIP}} 0 0

Version-Release number of selected component (if applicable):
All systems are fully up to date.

How reproducible:
Happens very often.

Steps to Reproduce:
1. Start evolution, read some e-mails
2. Evolution hangs
3. Error message is printed on all terminals
  
Additional info:
Message from syslogd@takashima at Apr 18 12:28:48 ...
 kernel:[61466.297585] Process evolution (pid: 12662, ti=f099e000 task=f1bbd7f0 task.ti=f099e000)

Message from syslogd@takashima at Apr 18 12:28:48 ...
 kernel:[61466.297587] Stack:

Message from syslogd@takashima at Apr 18 12:28:48 ...
 kernel:[61466.297608] Call Trace:

Message from syslogd@takashima at Apr 18 12:28:48 ...
 kernel:[61466.297696] Code: ff 90 e9 88 fe ff ff 8d 74 26 00 8d bc 27 00 00 00 00 55 89 e5 3e 8d 74 26 00 f0 80 48 34 04 5d c3 90 55 89 e5 53 3e 8d 74 26 00 <8b> 48 dc 31 c0 85 c9 74 13 8b 59 20 83 e2 03 21 d3 39 d3 75 07 

Message from syslogd@takashima at Apr 18 12:28:48 ...
 kernel:[61466.297731] EIP: [<fbd31329>] nfs_have_delegation+0x9/0x30 [nfs] SS:ESP 0068:f099fec8
Comment 1 Josh Boyer 2012-04-18 08:22:35 EDT

*** This bug has been marked as a duplicate of bug 811138 ***

Note You need to log in before you can comment on or make changes to this bug.