Bug 813755 - F17 Alpha PPC64: Text method installation throws exception on P7
F17 Alpha PPC64: Text method installation throws exception on P7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 07:20 EDT by IBM Bug Proxy
Modified: 2013-01-10 01:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 09:27:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
F17-installation-error (174.63 KB, image/png)
2012-04-18 07:20 EDT, IBM Bug Proxy
no flags Details
Firebrid-L-standalone-system-install-log.txt (33.16 KB, text/plain)
2012-05-11 03:21 EDT, IBM Bug Proxy
no flags Details
F17-beta-FirebirdL-exception.png (124.50 KB, image/png)
2012-05-17 10:11 EDT, IBM Bug Proxy
no flags Details
abrt-tmp.tgz (172.47 KB, application/x-compressed-tar)
2012-05-17 10:11 EDT, IBM Bug Proxy
no flags Details
anaconda.log (25.60 KB, text/plain)
2012-05-17 10:12 EDT, IBM Bug Proxy
no flags Details
anaconda-tb-b0QajZ (1.22 MB, text/plain)
2012-05-17 10:22 EDT, IBM Bug Proxy
no flags Details
anaconda-yum.conf (367 bytes, text/plain)
2012-05-17 10:22 EDT, IBM Bug Proxy
no flags Details
program.log (408.38 KB, text/plain)
2012-05-17 10:22 EDT, IBM Bug Proxy
no flags Details
storage.log (461.34 KB, text/plain)
2012-05-17 10:23 EDT, IBM Bug Proxy
no flags Details
syslog (88.89 KB, text/plain)
2012-05-17 10:23 EDT, IBM Bug Proxy
no flags Details
yum.log (143.38 KB, text/plain)
2012-05-17 10:23 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 80851 None None None Never

  None (edit)
Description IBM Bug Proxy 2012-04-18 07:20:23 EDT
== Comment: #0 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2012-04-18 05:26:20 ==
While installing F17 alpha PPC64 (Fedora-17-ppc64-DVD.iso) on Juno IOCL (P7) H/W , after all the packages gets installed, it throws exception before grub installation.

here is the back trace collected : (you can also see the attached screen shot  for the exception)
(Pdb) bt
  /usr/sbin/anaconda(852)<module>()
-> anaconda.dispatch.run()
  /usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py(326)run()
-> self.anaconda.intf.run(self.anaconda)
  /usr/lib64/python2.7/site-packages/pyanaconda/text.py(507)run()
-> self.anaconda.dispatch.dispatch()
  /usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py(383)dispatch()
-> self.dir = self.steps[self.step].target(self.anaconda)
  /usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py(2344)writeBootloader()
-> anaconda.bootloader.write()
  /usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py(1088)write()
-> self.write_config()
  /usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py(1755)write_config()
-> self.write_device_map()
  /usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py(1687)write_device_map()
-> devices = self.drives
> /usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py(383)drives()
-> self.stage1_drive = self._drives[0]

---steps to reproduce---
1) Existing system should have F16 GA installed with.
2) boot from F17 alpha ppc64 DVD
3) run linux askmethod
4) select text method installation instead of vnc
5) Under Partitioning Type , choose Replace existing Linux system
6) select Write Changes to Disk
7) when it completes 100% (Packages completed: 238 of 238) , it generates exceptions.

== Comment: #1 - SRINIVASA N. THIMALAPUR <srinivasa.tn@in.ibm.com> - 2012-04-18 06:16:27 ==
Hi Manas,
   Is it possible to get anaconda.log?  Also, is it possible to get the list of packages that were selected for installation?

Regards,
Seenu.

== Comment: #2 - MANAS K. NAYAK <maknayak@in.ibm.com> - 2012-04-18 06:24:15 ==
(In reply to comment #1)
Hi Seenu,
anaconda.log is unavailable as , I reinstall the system freshly.
This wasa text method installation , where you will not get option to choose packages.
It installs few default packages.

Thanks...
Manas
Comment 1 IBM Bug Proxy 2012-04-18 07:20:37 EDT
Created attachment 578321 [details]
F17-installation-error
Comment 2 IBM Bug Proxy 2012-04-18 09:10:38 EDT
------- Comment From baude@us.ibm.com 2012-04-18 13:02 EDT-------
Setting to needinfo as no log information has been provided.

Remember to use things like sshd or the hvc1 serial device trick to obtain logs for failed installations.
Comment 3 IBM Bug Proxy 2012-05-11 03:20:47 EDT
------- Comment From maknayak@in.ibm.com 2012-05-11 07:13 EDT-------
I could manage to reverify this issue on one of the LPAR and one of the Stand alone system.
I could not reproduce this issue on LPAR but I could notice similar issue while installing on stand alone system.

I have attached the installation console log file named " Firebrid-L-standalone-system-install-log.txt" from stand alone system , which reproduces similar issue.
Comment 4 IBM Bug Proxy 2012-05-11 03:21:02 EDT
Created attachment 583753 [details]
Firebrid-L-standalone-system-install-log.txt


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-11 07:13 EDT-------
Comment 5 IBM Bug Proxy 2012-05-11 08:51:13 EDT
------- Comment From baude@us.ibm.com 2012-05-11 12:48 EDT-------
Manas,

Same exact install scenario?  It seems to work but dies after all the packages are installed?  Is this system multipath by chance?  What was on the disk prior to this install?  And finally, have you replicated with any of the prebeta isos?
Comment 6 Chris Lumens 2012-05-14 10:29:51 EDT
If you can reproduce this, can you please grab /tmp/anaconda-tb-* and attach it to this bug report?
Comment 7 IBM Bug Proxy 2012-05-17 10:11:24 EDT
------- Comment From maknayak@in.ibm.com 2012-05-17 14:08 EDT-------
(In reply to comment #11)
> If you can reproduce this, can you please grab /tmp/anaconda-tb-* and attach
> it to this bug report?

Yes , I could reproduce this issue with Fedora 17 beta ppc64 on standalone Firebird-L blade.
I tried to boot from vmlinuz and initrd.img file from local hard disk and then went for http method installation with VNC installation , which leads to  "Index Error: list index out of range " before the boot loader configuration .

On stand alone system Firebird-L it is frequently reproducible.

I am attaching following logs grabbed from sshd console session.
anaconda-yum.conf  memory.dat   storage.state
anaconda.log                        program.log  syslog
anaconda-tb-b0QajZ              storage.log  yum.log

Also attached file F17beta-firebird-L-blade-http-install-console-log.txt.

Attached abrt-tmp.tgz which got collected by saving detail exception report log from vnc & the exception screen shot "F17-beta-FirebirdL-exception.png"

Thanks...
Manas
Comment 8 IBM Bug Proxy 2012-05-17 10:11:35 EDT
Created attachment 585228 [details]
F17-beta-FirebirdL-exception.png


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:09 EDT-------
Comment 9 IBM Bug Proxy 2012-05-17 10:11:49 EDT
Created attachment 585229 [details]
abrt-tmp.tgz


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:10 EDT-------
Comment 10 IBM Bug Proxy 2012-05-17 10:12:01 EDT
Created attachment 585230 [details]
anaconda.log


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:10 EDT-------
Comment 11 IBM Bug Proxy 2012-05-17 10:22:35 EDT
Created attachment 585232 [details]
anaconda-tb-b0QajZ


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:12 EDT-------
Comment 12 IBM Bug Proxy 2012-05-17 10:22:48 EDT
Created attachment 585233 [details]
anaconda-yum.conf


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:12 EDT-------
Comment 13 IBM Bug Proxy 2012-05-17 10:22:58 EDT
Created attachment 585235 [details]
program.log


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:13 EDT-------
Comment 14 IBM Bug Proxy 2012-05-17 10:23:11 EDT
Created attachment 585236 [details]
storage.log


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:13 EDT-------
Comment 15 IBM Bug Proxy 2012-05-17 10:23:23 EDT
Created attachment 585237 [details]
syslog


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:14 EDT-------
Comment 16 IBM Bug Proxy 2012-05-17 10:23:35 EDT
Created attachment 585238 [details]
yum.log


------- Comment (attachment only) From maknayak@in.ibm.com 2012-05-17 14:15 EDT-------
Comment 17 IBM Bug Proxy 2012-05-17 15:22:27 EDT
------- Comment From baude@us.ibm.com 2012-05-17 19:14 EDT-------
In your syslog file, we see the following:

00:16:54,632 NOTICE kernel:[    0.000000] Kernel command line: root=/dev/mapper/vg_ltcfbl78b-lv_root ro root=live:/dev/sda2 serial debug rd.debug sshd vnc repo=http://http://9.3.190.193/f17beta ip=9.3.190.171::9.3.190.1:255.255.255.0:ltcfbl78b.austin.ibm.com:eth0:none  dns=9.3.190.33

We again wonder how you are booting this, how multiple root= appends are getting added, we also see the use of serial and dns which is deprecated.
Comment 18 IBM Bug Proxy 2012-05-21 05:12:40 EDT
------- Comment From maknayak@in.ibm.com 2012-05-21 09:07 EDT-------
(In reply to comment #22)
> In your syslog file, we see the following:
>
> 00:16:54,632 NOTICE kernel:[    0.000000] Kernel command line:
> root=/dev/mapper/vg_ltcfbl78b-lv_root ro root=live:/dev/sda2 serial debug
> rd.debug sshd vnc repo=http://http://9.3.190.193/f17beta
> ip=9.3.190.171::9.3.190.1:255.255.255.0:ltcfbl78b.austin.ibm.com:eth0:none
> dns=9.3.190.33
>
> We again wonder how you are booting this, how multiple root= appends are
> getting added, we also see the use of serial and dns which is deprecated.

Hi Brent,
I was booting from hard disk locally with intird.img and vmlinuz after configuring yaboot.conf file on existing OS.

I retried with booting from DVD and provided installation repo as HTTP server , it worked as expected and Firebrid-L standalone system got installed with F17 beta. I did not see any issue with F17 beta.

So looks like f17 beta has fix for this kind of issue.

Thanks...
Manas

Note You need to log in before you can comment on or make changes to this bug.