Bug 813756 - eclipse-jdt: bundled junit library
eclipse-jdt: bundled junit library
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2012-04-18 07:22 EDT by Mikolaj Izdebski
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version: eclipse-4.2.0-0.17.I201204171000.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 01:04:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-04-18 07:22:09 EDT
eclipse-jdt is bundling junit library:

$ ls -go ./usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100.jar
-rw-r--r--. 1 328768 Apr 18 13:11 ./usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100.jar
Comment 1 Roland Grunberg 2012-04-18 10:29:53 EDT
This is actually the the same junit.jar provided in %{_javadir} with the only difference being that the OSGi metadata is different. I think this could probably be removed. Initially this was to allow tycho to resolve against junit3, if necessary, but looking at the logs I see this isn't necessary any longer.
Comment 2 Krzysztof Daniel 2012-04-18 10:33:52 EDT
I think Eclipse requires it. I will convert it into a symlink.
Comment 3 Krzysztof Daniel 2012-04-19 03:01:40 EDT
As per upstream bug, expected bundles are:
org.junit_3.8.x
org.junit_4.8.x
org.junit4_4.8.x

we have:
-rw-r--r--. 1 root root 328768 org.junit_3.8.2.v3_8_2_v20100427-1100.jar (wrong, should be symlink)
lrwxrwxrwx. 1 root root       26 Apr 12 10:05 junit4.jar -> /usr/share/java/junit4.jar (ok, corresponding to org.junit_4.8.x)

drwxr-xr-x. 2 root root     4096 Apr 12 10:05 org.junit4 (it has a symlink to junit4.jar inside, looks like a duplication, to be removed).
drwxr-xr-x. 3 root root     4096 Apr 12 10:05 org.junit4_4.8.1.v20111115-0800  (ok)
lrwxrwxrwx. 1 root root       25 Apr 12 10:05 org.junit_4.8.2.v4_8_2_v20110321-1705.jar -> /usr/share/java/junit.jar (duplication)
Comment 4 Fedora Update System 2012-04-19 10:02:35 EDT
eclipse-4.2.0-0.15.I201204171000.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-4.2.0-0.15.I201204171000.fc17
Comment 5 Fedora Update System 2012-04-19 22:25:21 EDT
Package eclipse-4.2.0-0.15.I201204171000.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-4.2.0-0.15.I201204171000.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6220/eclipse-4.2.0-0.15.I201204171000.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-20 06:15:10 EDT
eclipse-4.2.0-0.16.I201204171000.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-4.2.0-0.16.I201204171000.fc17
Comment 7 Roland Grunberg 2012-04-20 13:01:12 EDT
Looking at the fix I see that there are 2 org.junit v4.8.2 jars. One is a symlink to %{_javadir}/junit.jar and the other at %{_libdir}/eclipse/dropins/jdt/plugins/org.junit_4.8.2.v4_8_2_v20110321-1705.jar . Both seem to be identical. Would it be possible to remove one of them ?

I ran a build of tycho against this new eclipse-jdt package and it fails because there are 2 junit jars with the same symbolicname, and version but with different locations on the system. Initially this passed because in previous versions, both were symlinks to the same file.
Comment 8 Krzysztof Daniel 2012-04-23 03:48:52 EDT
e-b removed the Junit source very early (and indeed, after a build, the builddirectory/plugins does not have org.junit_4*.jar, just junit symlink. I guess it is because of the PDEBuild, and the only solution for that is to delete the redundant plugin in Eclipse.spec.
Comment 9 Fedora Update System 2012-04-23 09:34:31 EDT
eclipse-4.2.0-0.17.I201204171000.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-4.2.0-0.17.I201204171000.fc17
Comment 10 Fedora Update System 2012-04-25 01:04:42 EDT
eclipse-4.2.0-0.17.I201204171000.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.