Bug 813764 - Enable system lzo library on rhel >= 6
Enable system lzo library on rhel >= 6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvncserver (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 813498
  Show dependency treegraph
 
Reported: 2012-04-18 07:39 EDT by Petr Pisar
Modified: 2012-04-19 23:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: libvncserver-0.9.8.2-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 23:06:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Do not use system lzo library on RHEL <= 5 only (1.17 KB, patch)
2012-04-18 07:39 EDT, Petr Pisar
no flags Details | Diff

  None (edit)
Description Petr Pisar 2012-04-18 07:39:14 EDT
Created attachment 578324 [details]
Do not use system lzo library on RHEL <= 5 only

Since RHEL 6, the lzo library is available in RHEL repositories. Current libvncserver uses bundled library on rhel builds now. To unbundle the lzo library, I propose refine the system_minilzo macro condition to enable it on RHEL >= 6.

Attached patch implement it. I can apply it if you are busy.
Comment 1 Fedora Update System 2012-04-18 08:14:25 EDT
libvncserver-0.9.8.2-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvncserver-0.9.8.2-4.fc17
Comment 2 Rex Dieter 2012-04-18 10:06:58 EDT
Just to make sure, did you really mean >=6 or for rhel7 ?
Comment 3 Rex Dieter 2012-04-18 10:07:38 EDT
Nevermind, read your initial comment closer now, it's pretty clear you meant what you said. :)
Comment 4 Petr Pisar 2012-04-18 10:10:30 EDT
Thank you for quick response. Originally I was aiming rhel7, but while checking rhel6, I found the library is there too, so I allowed using the library since rhel6.
Comment 5 Fedora Update System 2012-04-18 18:14:22 EDT
Package libvncserver-0.9.8.2-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvncserver-0.9.8.2-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6155/libvncserver-0.9.8.2-4.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-19 23:06:22 EDT
libvncserver-0.9.8.2-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.