Bug 813786 - SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the sock_file /run/winbindd/pipe. The samba server needs to be able to read from winbind for user lists.
SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the sock_file...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5fb00c8e0650dcdcaab4d76c8f0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 08:40 EDT by Stef Walter
Modified: 2012-04-20 11:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 11:02:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2012-04-18 08:40:17 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.1-5.fc17.x86_64
time:           Wed 18 Apr 2012 02:39:47 PM CEST

description:
:SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the sock_file /run/winbindd/pipe.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that smbd should be allowed getattr access on the pipe sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep smbd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:smbd_t:s0
:Target Context                unconfined_u:object_r:var_run_t:s0
:Target Objects                /run/winbindd/pipe [ sock_file ]
:Source                        smbd
:Source Path                   /usr/sbin/smbd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           samba-3.6.4-82.fc17.1.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.3.1-5.fc17.x86_64 #1 SMP Tue Apr 10 20:42:28 UTC
:                              2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 18 Apr 2012 02:37:37 PM CEST
:Last Seen                     Wed 18 Apr 2012 02:37:37 PM CEST
:Local ID                      68951272-3ab1-4de4-a0a5-0065397bf1ab
:
:Raw Audit Messages
:type=AVC msg=audit(1334752657.632:547): avc:  denied  { getattr } for  pid=30511 comm="smbd" path="/run/winbindd/pipe" dev="tmpfs" ino=3458519 scontext=system_u:system_r:smbd_t:s0 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1334752657.632:547): arch=x86_64 syscall=lstat success=no exit=EACCES a0=7f5b869c8130 a1=7fffa63409d0 a2=7fffa63409d0 a3=17 items=0 ppid=1 pid=30511 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=smbd exe=/usr/sbin/smbd subj=system_u:system_r:smbd_t:s0 key=(null)
:
:Hash: smbd,smbd_t,var_run_t,sock_file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-04-20 10:33:28 EDT
Looks like you have a mislabeled directory.

restorecon -R -v /run/winbindd

Did you run winbindd outsite of the init script?
Comment 2 Stef Walter 2012-04-20 11:02:40 EDT
Yes, I probably did.

[stef@stef-desktop pbis]$ sudo restorecon -R -v /run/winbindd
[sudo] password for stef: 
restorecon reset /run/winbindd context unconfined_u:object_r:var_run_t:s0->unconfined_u:object_r:winbind_var_run_t:s0
restorecon reset /run/winbindd/pipe context unconfined_u:object_r:var_run_t:s0->unconfined_u:object_r:winbind_var_run_t:s0

So I guess this is a bogus report. Closing.

Note You need to log in before you can comment on or make changes to this bug.