Bug 813794 - can not run more than once e2fsck on a filesystem .
can not run more than once e2fsck on a filesystem .
Status: CLOSED DUPLICATE of bug 808795
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 08:54 EDT by Pascal Chapperon
Modified: 2012-04-18 10:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 10:26:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sequence of umount, fsck, mount commands + fuser -m (2.79 KB, text/plain)
2012-04-18 08:54 EDT, Pascal Chapperon
no flags Details

  None (edit)
Description Pascal Chapperon 2012-04-18 08:54:24 EDT
Created attachment 578343 [details]
sequence of umount, fsck, mount commands + fuser -m

Description of problem:
Under a gnome-terminal session (graphical) or a tty session (multi_user), you can umount a filesystem described in /etc/fstab and perform a fsck, but just once; if you remount the filesystem, and then umount it, fsck fails. (see attachment)


Version-Release number of selected component (if applicable):
Fedora 16 systemd-37.17

How reproducible:
see attachement.

Steps to Reproduce:
1. umount a filesystem
2. perform a fsck on the filesystem
3. mount it
4. umount it
5. perform a fsck
  
Actual results:
The first fsck succeeds, the second one fails.

Expected results:
Both must succeed.

Additional info:
Comment 1 Pascal Chapperon 2012-04-18 08:57:10 EDT
Similarly, you can remove a logical volume that was not mounted at boot, but once mounted, no matter :

[root@euler ~]# lvremove /dev/vg_euler/test 
Do you really want to remove active logical volume test? [y/n]: n
  Logical volume test not removed
[root@euler ~]# mount /dev/vg_euler/test /mnt
[root@euler ~]# umount /mnt
[root@euler ~]# lvremove /dev/vg_euler/test 
  Can't remove open logical volume "test"
[root@euler ~]# lvchange -an /dev/vg_euler/test
  LV vg_euler/test in use: not deactivating
[root@euler ~]# fuser -m /dev/vg_euler/test
/dev/dm-1:               1   442   574   978   995  1007  1022  1030  
1034  1041  1048  1050  1051  1058m  1062  1063  1064  1141
 1142  1143  1146  1153  1155m  1161  1165  1167  1184  1185 
 1190  1199  1200  1262  1265  1276  1357  1359  1369  1370 
 1374  1396  1398  1421  1422  1425  1427  1436  1439  1440 
 1447  1450  1451m  1457  1458  1459  1463  1465  1467  1471
  1474  1485  1494  1507  1520  1527  1548  1559  1567  1571 
 1591  1615  1617  1625  1629  1630  1633  1702  1708  2044  2080  
2138
Comment 2 Michal Schmidt 2012-04-18 09:27:46 EDT
Does it work after "chkconfig sandbox off && reboot"? If yes, it is a duplicate of bug 808795.
Comment 3 Pascal Chapperon 2012-04-18 10:25:58 EDT
lvremove works well after disabling sandbox :

[root@euler ~]# mount /dev/vg_euler/test /mnt
[root@euler ~]# umount /mnt
[root@euler ~]# lvremove /dev/vg_euler/test
Do you really want to remove active logical volume test? [y/n]: n
  Logical volume test not removed
[root@euler ~]# mount /dev/vg_euler/test /mnt
[root@euler ~]# umount /mnt
[root@euler ~]# lvremove /dev/vg_euler/test
Do you really want to remove active logical volume test? [y/n]: y
  Logical volume "test" successfully removed

However, fsck is still not working properly : 
- under graphical.target, the first umount/fsck now fails.
- under multi-user.target, I can now run umount/fsck/mount as many time as I want (just once before removing sandbox).

But I agree with you, this report is a duplicate of 808795.
Comment 4 Pascal Chapperon 2012-04-18 10:26:23 EDT

*** This bug has been marked as a duplicate of bug 808795 ***

Note You need to log in before you can comment on or make changes to this bug.