Bug 813810 - plug small race window at the end of block_stream command
plug small race window at the end of block_stream command
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks: 806280 813862
  Show dependency treegraph
 
Reported: 2012-04-18 09:22 EDT by Paolo Bonzini
Modified: 2012-06-20 07:46 EDT (History)
13 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.286.el6
Doc Type: Bug Fix
Doc Text:
NEEDINFO
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:46:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2012-04-18 09:22:47 EDT
Kevin noted how the part of stream_run() that is after the for loop runs with s->common.busy = false. At least bdrv_change_backing_file() can yield, possibly other functions, too.

The race window is really small but it's there.  We can extend the implementation of block_job_cancel_sync so that the race can be fixed easily.

The same patches help fixing the case where the target of a mirroring job fails during block_job_cancel_sync, as suggested by Marcelo.

[To qa: it is very hard to cover these particular cases with tests, but the streaming and mirroring tests---for example switching mirroring to the target, and quit during streaming---will ensure that the code works well].
Comment 4 Michal Novotny 2012-05-04 09:31:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
NEEDINFO
Comment 7 errata-xmlrpc 2012-06-20 07:46:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0746.html

Note You need to log in before you can comment on or make changes to this bug.