Bug 813818 - gnome-shell no longer starts after "yum distro-sync"
gnome-shell no longer starts after "yum distro-sync"
Status: CLOSED DUPLICATE of bug 803760
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 09:35 EDT by Brian Johnson
Modified: 2012-04-18 23:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 14:49:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors file from my home desktop, "razorclaw" (8.05 KB, application/octet-stream)
2012-04-18 10:22 EDT, Brian Johnson
no flags Details

  None (edit)
Description Brian Johnson 2012-04-18 09:35:24 EDT
Description of problem: 
Yesterday I remotely upgraded my desktop using preupgrade-cli. That worked as expected and when I got home, I reboot and completed the upgrade with no issue. After installation completed, machine reboot logged in again with no problems. Then went to following the preupgrade post-install steps listed at https://fedoraproject.org/wiki/How_to_use_PreUpgrade. When I did the last step, "yum distro-sync", it looked like it was updating packages. It completed, I rebooted, booted fine, but when I tried to log in as myself, I know longer get gnome-shell, but a screen showing nothing but my background. Cannot perform anything as I would in gnome-shell (alt-f2 to run programs, alt-f1 to bring up activities window) and doing a 'ps -ef | grep gnome-shell' returns nothing.


Version-Release number of selected component (if applicable):
gnome-shell-3.4.0-1.fc17.i686

How reproducible:
Anytime I now try to log in.


Steps to Reproduce:
1. Use preupgrade to go from fully updated F16 install to F17 beta
2. run post-install steps at https://fedoraproject.org/wiki/How_to_use_PreUpgrade, particularly "yum distro-sync"
3. reboot and log into gnome.
  
Actual results:
taken to a desktop that shows nothing but my background, has nothing from gnome-shell

Expected results:
See my normal Gnome desktop

Additional info:
Logs from /var/log/messages pertaining to gnome-shell:

Apr 18 07:56:25 razorclaw gnome-session[1100]: DEBUG(+): fill: *** Launching helper 'bash -c 'gnome-shell --help | grep -q gdm-mode && /usr/libexec/gnome-session-check-accelerated'' to know if session is runnable
Apr 18 07:56:26 razorclaw gnome-session[1100]: DEBUG(+): GsmUtil: Looking for file 'gnome-shell.desktop'
Apr 18 07:56:26 razorclaw gnome-session[1100]: DEBUG(+): GsmUtil: found in XDG dirs: '/usr/share/gdm/greeter/applications/gnome-shell.desktop'
Apr 18 07:56:26 razorclaw gnome-session[1100]: DEBUG(+): GsmUtil: Looking for file 'gnome-shell.desktop'
Apr 18 07:56:26 razorclaw gnome-session[1100]: DEBUG(+): GsmUtil: found in XDG dirs: '/usr/share/gdm/greeter/applications/gnome-shell.desktop'
Apr 18 07:56:26 razorclaw gnome-session[1100]: DEBUG(+): GsmManager: read /usr/share/gdm/greeter/applications/gnome-shell.desktop
Apr 18 07:56:26 razorclaw gnome-session[1100]: DEBUG(+): GsmManager: adding required app gnome-shell.desktop
Apr 18 07:56:26 razorclaw gnome-session[1100]: DEBUG(+): GsmManager:#011ID: /org/gnome/SessionManager/App1#011app-id:gnome-shell.desktop#011is-disabled:0#011is-conditionally-disabled:0
Apr 18 07:56:27 razorclaw gnome-session[1100]: DEBUG(+): GsmAutostartApp: starting gnome-shell.desktop: command=gnome-shell --gdm-mode startup-id=10e9d7ab514aeff138133475018655224700000011000000
Apr 18 07:56:27 razorclaw gnome-session[1100]: DEBUG(+): GsmXSMPClient:   Program = 'gnome-shell'
Apr 18 07:56:28 razorclaw dbus-daemon[806]: dbus[806]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.33" (uid=42 pid=1174 comm="gnome-shell --gdm-mode ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.17" (uid=0 pid=1030 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Apr 18 07:56:28 razorclaw dbus[806]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.33" (uid=42 pid=1174 comm="gnome-shell --gdm-mode ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.17" (uid=0 pid=1030 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Apr 18 07:56:45 razorclaw gnome-session[1100]: DEBUG(+): GsmXSMPClient: Client '0x960e940 [gnome-shell 10e9d7ab514aeff138133475018655224700000011000000]' received SaveYourselfDone(success = True)
Apr 18 07:56:45 razorclaw gnome-session[1100]: DEBUG(+): GsmXSMPClient: Client '0x960e940 [gnome-shell 10e9d7ab514aeff138133475018655224700000011000000]' received SaveYourselfDone(success = True)
Apr 18 07:56:45 razorclaw gnome-session[1100]: DEBUG(+): GsmXSMPClient: xsmp_stop ('0x960e940 [gnome-shell 10e9d7ab514aeff138133475018655224700000011000000]')
Apr 18 07:56:45 razorclaw gnome-session[1100]: DEBUG(+): GsmXSMPClient: Client '0x960e940 [gnome-shell 10e9d7ab514aeff138133475018655224700000011000000]' received CloseConnection
Apr 18 07:56:45 razorclaw gnome-session[1100]: DEBUG(+): GsmXSMPClient: xsmp_finalize (0x960e940 [gnome-shell 10e9d7ab514aeff138133475018655224700000011000000])
Apr 18 07:57:04 razorclaw dbus-daemon[806]: dbus[806]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.66" (uid=1000 pid=1434 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.17" (uid=0 pid=1030 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Apr 18 07:57:04 razorclaw dbus[806]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.66" (uid=1000 pid=1434 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.17" (uid=0 pid=1030 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Comment 1 Owen Taylor 2012-04-18 10:08:24 EDT
These are all messages about the GDM session, which is apparentl working correctly, since you were able to atempt to log in to your desktop. (IIs the appearance of GDM "black and shiny"? GNOME Shell is used to display that user interface for GDM, though GDM also has fallback code for systems without GL)
 
 - Can you log into the desktop of a newly created user?
 - Is anything written into ~/.xsession-errors when you try to log in and get the blank display?
Comment 2 Brian Johnson 2012-04-18 10:22:06 EDT
Created attachment 578368 [details]
.xsession-errors file from my home desktop, "razorclaw"
Comment 3 Brian Johnson 2012-04-18 10:24:45 EDT
Thank you for the quick response!

I'm sorry about the GDM logs, as I thought they might have something in there as to way gnome-shell wasn't starting.

GDM is, in fact, "black and shiny" when I try to log in, similar to the look of gnome 3 and not the gray, square fallback alternative.

I won't be home until this evening so I won't be able to try to log in as another user until then, I'm afraid.

I did in fact have something written in .xsession-errors, presumably from my attempt this morning (the only time/date stamps I saw were for 18/04/2012). I've attached that file to this ticket as "razorclaw-xsession".

Thanks!

(In reply to comment #1)
> These are all messages about the GDM session, which is apparentl working
> correctly, since you were able to atempt to log in to your desktop. (IIs the
> appearance of GDM "black and shiny"? GNOME Shell is used to display that user
> interface for GDM, though GDM also has fallback code for systems without GL)
> 
>  - Can you log into the desktop of a newly created user?
>  - Is anything written into ~/.xsession-errors when you try to log in and get
> the blank display?
Comment 4 Owen Taylor 2012-04-18 14:49:55 EDT
Problem here is that you have the Pidgin extension installed both in your account and on the system. The crash this causes is fixed in gnome-shell-3.4.1, which should be hitting updates-testing within the next few days. For now, if you uninstall the system version, you should be able to log in.

*** This bug has been marked as a duplicate of bug 803760 ***
Comment 5 Brian Johnson 2012-04-18 15:06:18 EDT
Thank you very much, I'm glad it was that simple!

Just a point of clarity, when you talk about the "system version", are you talking about gnome-shell-extension-pidgin that was installed via yum? I'm ssh'd into the machine now and did a 'yum remove gnome-shell-extension-pidgin' of that package so that's been removed and I will reboot when I get home.

If that's not what I need to do, can you please let me know how I need to do it? Thanks!

(In reply to comment #4)
> Problem here is that you have the Pidgin extension installed both in your
> account and on the system. The crash this causes is fixed in gnome-shell-3.4.1,
> which should be hitting updates-testing within the next few days. For now, if
> you uninstall the system version, you should be able to log in.
> 
> *** This bug has been marked as a duplicate of bug 803760 ***
Comment 6 Brian Johnson 2012-04-18 23:52:42 EDT
Thank you very much, removing the gnome-shell-extension-pidgin fixed the issue. Came home, did a ctl-alt-bkspace, signed back in, and all worked as it should.

Note You need to log in before you can comment on or make changes to this bug.