Bug 813820 - resize2fs: update resize2fs manpage with on-line ext4 resizing
Summary: resize2fs: update resize2fs manpage with on-line ext4 resizing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: e2fsprogs
Version: 6.2
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: Eryu Guan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-18 13:45 UTC by Martin Chlumsky
Modified: 2013-02-21 10:48 UTC (History)
2 users (show)

Fixed In Version: e2fsprogs-1.41.12-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:48:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0455 normal SHIPPED_LIVE e2fsprogs bug fix update 2013-02-20 21:07:38 UTC

Description Martin Chlumsky 2012-04-18 13:45:21 UTC
Description of problem:
The man page of resize2fs implies that only ext3 filesystems are resizable while they are mounted. From the man page:

(As of this  writing, the Linux 2.6 kernel supports on-line resize for filesystems mounted using ext3 only.)

However ext4 are resizable while being mounted according to this page:
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Storage_Administration_Guide/ext4grow.html


Version-Release number of selected component (if applicable):

e2fsprogs-1.41.12-11.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Run man resize2fs
2. Read the first paragraph of the man page

  
Actual results:
Man page reads:
(As of this  writing, the Linux 2.6 kernel supports on-line resize for filesystems mounted using ext3 only.)

Expected results:
It should read something like this:
(As of this  writing, the Linux 2.6 kernel supports on-line resize for filesystems mounted using ext3 and ext4 only.)

Additional info:

Comment 2 Eric Sandeen 2012-04-18 15:52:11 UTC
There are a few other manpages to be updated as well; this has already been done upstream:

commit 4f858546e1c3c452f400a34198b10cb7a1ed2760
Author: Theodore Ts'o <tytso@mit.edu>
Date:   Sat May 30 12:34:28 2009 -0400

    Update man pages to include ext4 in the synposis, instead of just "ext2/ext3"
    
    The e2fsprogs programs have historically just said that they operate
    on ext2 and ext3 file system in their man pages.  Update them to say
    that they also operate on ext4 file systems.
    
    Addresses-Launchpad-bug: #381854
    
    Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>

Comment 3 RHEL Product and Program Management 2012-07-10 08:38:39 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2012-07-10 23:07:15 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 5 RHEL Product and Program Management 2012-08-14 22:00:28 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 6 Eric Sandeen 2012-10-12 13:43:38 UTC
Actually the previous commit I mentioned is already in rhel6; the small update is:

commit b344ed7bc3b7e1aeed9c2f8f1ec089117a444366
Author: Theodore Ts'o <tytso@mit.edu>
Date:   Mon Jul 19 02:23:12 2010 -0400

    resize2fs.8: Update man page to indicate ext4 supports on-line resize

Comment 8 Eryu Guan 2012-12-19 06:17:21 UTC
Verified man page was updated.

Set to VERIFIED.

Comment 10 errata-xmlrpc 2013-02-21 10:48:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0455.html


Note You need to log in before you can comment on or make changes to this bug.