This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 813868 - <backspace> echoes as "0008 in a box"
<backspace> echoes as "0008 in a box"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
17
powerpc Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 11:54 EDT by John Reiser
Modified: 2012-06-26 11:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 11:32:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.0.log (53.12 KB, text/plain)
2012-04-18 11:54 EDT, John Reiser
no flags Details
syslog (/var/log/messages) (157.78 KB, text/plain)
2012-04-18 11:55 EDT, John Reiser
no flags Details
$HOME/.xsession-errors (2.62 KB, text/plain)
2012-04-18 12:42 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2012-04-18 11:54:11 EDT
Created attachment 578402 [details]
/var/log/Xorg.0.log

Description of problem: In gnome-terminal (bash command line), a <backspace> echoes as "0008 in a box" instead of visually erasing the previous character.  Typing "date\b\r" gives "dat: not found", so the 'e' was removed from the string that was delivered to the shell; but the display shows five characters: "date" followed by "0008 in a box".  This happens running gnome-terminal under both Gnome3 session (fallback mode) and Xfce session.  The Xfce Terminal app behaves correctly (<backspace> visually erases the previous character) under both Gnome3 session and Xfce session.


Version-Release number of selected component (if applicable):
gnome-terminal-3.4.0.1-1.fc17.ppc
gnome-session-3.4.0-1.fc17.ppc
gnome-session-xsession-3.4.0-1.fc17.ppc


How reproducible: every time


Steps to Reproduce:
1. type "date\b\r" as the first input to a gnome-terminal.
2.
3.
  
Actual results: Displays as "date" followed by "0008 in a box".  bash complains "dat: not found."


Expected results: Displays as "dat" (without the 'e' and without the "0008 in a box"), followed by bash complaint "dat: not found".


Additional info: Font is monospace 9.  Box is Apple Macintosh Mini G4 PowerPC, which is big-endian.

 lspci says:
0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
0000:00:10.0 0300: 1002:5962 (rev 01)
Comment 1 John Reiser 2012-04-18 11:55:52 EDT
Created attachment 578403 [details]
syslog (/var/log/messages)
Comment 2 John Reiser 2012-04-18 12:42:04 EDT
Created attachment 578407 [details]
$HOME/.xsession-errors
Comment 3 John Reiser 2012-04-18 12:45:47 EDT
xorg-x11-drv-ati-6.14.3-11.20120206git36c190671.fc17.ppc
xorg-x11-server-Xorg-1.11.99.901-6.20120124.fc17.ppc
xorg-x11-fonts-ISO8859-1-100dpi-7.5-5.fc17.noarch
xorg-x11-font-utils-7.5-7.fc17.ppc
mesa-dri-drivers-8.0.1-2.fc17.ppc
kernel-3.3.1-5.fc17.ppc
Comment 4 Matthias Clasen 2012-05-08 09:12:38 EDT
I have had no luck reproducing this. Useful pieces of information would include:

your locale settings: env | grep LANG\\\|LC

gnome-terminals charset encoding: gconftool-2 --get /apps/gnome-terminal/global/active_encodings

the font: gconftool-2 --get /apps/gnome-terminal/profiles/Default/font
Comment 5 John Reiser 2012-05-08 11:05:01 EDT
$ env | grep LANG\\\|LC
LANG=en_US.UTF-8
$ gconftool-2 --get
/apps/gnome-terminal/global/active_encodings
No value set for `/apps/gnome-terminal/global/active_encodings'
$ gconftool-2 --get /apps/gnome-terminal/profiles/Default/font
Monospace 12

Note again that this is PowerPC (Apple Macintosh Mini "G4"), which is big-endian.
Comment 6 Matthias Clasen 2012-05-15 16:15:41 EDT
It sounds plausible that an endianness bug might be responsible, but I don't really have any good idea where to look for it...
Comment 7 Gustavo Luiz Duarte 2012-06-26 09:46:31 EDT
This issue is caused by a broken glib2. It is fixed on the latest glib2 available from updates (glib2-2.32.3-1.fc17).
For the record, the glib2 bug is caused by endian issue on GResource API. Upstream bugz: https://bugzilla.gnome.org/show_bug.cgi?id=673409

Please update to glib2-2.32.3-1.fc17 to verify the fix.
Comment 8 Matthias Clasen 2012-06-26 11:03:21 EDT
ah, thanks for tracking that down
Comment 9 John Reiser 2012-06-26 11:32:02 EDT
Confirmed fixed in glib2-2.32.3-1.fc17.ppc (self-built from .src.rpm).

Note You need to log in before you can comment on or make changes to this bug.