Bug 813888 - [abrt] kernel: BUG: soft lockup - CPU#0 stuck for 23s! [kworker/u:0:5]
[abrt] kernel: BUG: soft lockup - CPU#0 stuck for 23s! [kworker/u:0:5]
Status: CLOSED DUPLICATE of bug 811142
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:ecfe9c2c1a2c40dd43c066e3144...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 12:52 EDT by Emilia S.
Modified: 2012-09-18 11:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 11:30:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emilia S. 2012-04-18 12:52:51 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.1-3.fc16.i686 root=UUID=7407ed42-9a74-4369-bdc8-7baa7556a103 ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=pl2 LANG=pl_PL.UTF-8
kernel:         3.3.1-3.fc16.i686
reason:         BUG: soft lockup - CPU#0 stuck for 23s! [kworker/u:0:5]
time:           sob, 14 kwi 2012, 05:29:45

backtrace:
:BUG: soft lockup - CPU#0 stuck for 23s! [kworker/u:0:5]
:Modules linked in: be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio fcoe lockd libfcoe libfc ib_iser scsi_transport_fc scsi_tgt rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr 8021q garp stp llc iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack binfmt_misc acer_wmi sparse_keymap uvcvideo videobuf2_core videodev media videobuf2_vmalloc videobuf2_memops arc4 ath9k microcode mac80211 joydev ath9k_common snd_hda_codec_conexant ath9k_hw ath cfg80211 rfkill atl1c snd_hda_codec_hdmi k10temp snd_hda_intel snd_hda_codec snd_hwdep sp5100_tco snd_seq i2c_piix4 snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc sunrpc uinput ums_realtek usb_storage video wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Modules linked in: be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio fcoe lockd libfcoe libfc ib_iser scsi_transport_fc scsi_tgt rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr 8021q garp stp llc iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack binfmt_misc acer_wmi sparse_keymap uvcvideo videobuf2_core videodev media videobuf2_vmalloc videobuf2_memops arc4 ath9k microcode mac80211 joydev ath9k_common snd_hda_codec_conexant ath9k_hw ath cfg80211 rfkill atl1c snd_hda_codec_hdmi k10temp snd_hda_intel snd_hda_codec snd_hwdep sp5100_tco snd_seq i2c_piix4 snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc sunrpc uinput ums_realtek usb_storage video wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 5, comm: kworker/u:0 Not tainted 3.3.1-3.fc16.i686 #1 Acer AO722/JE10-BZ
:EIP: 0060:[<c065fc02>] EFLAGS: 00000296 CPU: 0
:EIP is at ioread32+0x32/0x40
:EAX: 00000000 EBX: f1be9140 ECX: f9516188 EDX: 0001618c
:ESI: f1be9140 EDI: f30065c0 EBP: f30a7f18 ESP: f30a7f18
: DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
:Process kworker/u:0 (pid: 5, ti=f30a6000 task=f307b240 task.ti=f30a6000)
:Stack:
: f30a7f30 f8b2374d f1be9140 f1be4000 f1be9140 f30065c0 f30a7f40 f8b8babb
: 00000000 f1bec410 f30a7f54 f8b27730 f1bec410 f1bec414 f30065c0 f30a7f94
: c044feab 00000000 f30a7f68 c0c8b840 f30a7f74 00001000 f2bae405 00c8c940
:Call Trace:
: [<f8b2374d>] ath9k_ioread32+0x2d/0x80 [ath9k]
: [<f8b8babb>] ar9003_get_pll_sqsum_dvc+0x5b/0x80 [ath9k_hw]
: [<f8b27730>] ath_hw_pll_work+0x50/0xd0 [ath9k]
: [<c044feab>] process_one_work+0xfb/0x390
: [<f8b276e0>] ? ath_hw_check+0xb0/0xb0 [ath9k]
: [<c0450b41>] worker_thread+0x121/0x2d0
: [<c0450a20>] ? manage_workers+0x1f0/0x1f0
: [<c0454f62>] kthread+0x72/0x80
: [<c0454ef0>] ? kthread_freezable_should_stop+0x60/0x60
: [<c0935e3e>] kernel_thread_helper+0x6/0x10
:Code: e5 77 26 3d 00 00 01 00 76 07 0f b7 d0 ed 5d c3 90 ba d2 a4 ab c0 e8 4e fe ff ff b8 ff ff ff ff 5d c3 8d b4 26 00 00 00 00 8b 00 <5d> c3 8d b6 00 00 00 00 8d bf 00 00 00 00 55 3d ff ff 03 00 89 

comment:
:The problem occurs every time I try to turn on wifi. In this case it happened on the system startup right after the wifi diod turned on.
:I have Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01).
:It happened on both Gnome and XFCE.

smolt_data:
:
:
:Ogólne
:=================================
:UUID: cac86a4b-1582-40f9-bbe8-f26dd45b72b7
:System operacyjny: Fedora release 16 (Verne)
:Domyślny poziom uruchamiania: Unknown
:Język: pl_PL.UTF-8
:Platforma: i686
:BogoMIPS: 1994.91
:Producent procesora: AuthenticAMD
:Model procesora: AMD C-60 APU with Radeon(tm) HD Graphics
:Stepping procesora: 0
:Rodzina procesora: 20
:Numer modelu procesora: 2
:Liczba procesorów: 2
:Prędkość procesora: 1000
:Pamięć systemu: 3528
:Przestrzeń wymiany systemu: 5583
:Producent: Acer
:System: AO722 V1.08
:Konstrukcja płyty głównej: Notebook
:Jądro: 3.1.0-7.fc16.i686
:SELinux jest włączony: 1
:Polityka SELinuksa: targeted
:Wymuszanie SELinuksa: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Urządzenia
:=================================
:(4098:17297:4133:1432) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4130:5392:4133:1432) pci, None, HOST/PCI, Family 14h Processor Root Complex
:(4098:4884:4133:1432) pci, snd_hda_intel, MULTIMEDIA, Wrestler HDMI Audio [Radeon HD 6250/6310]
:(4098:38919:4133:1432) pci, radeon, VIDEO, N/A
:(4130:5912:0:0) pci, None, HOST/PCI, Family 12h/14h Processor Function 6
:(4130:5892:0:0) pci, None, HOST/PCI, Family 12h/14h Processor Function 4
:(4130:5913:0:0) pci, None, HOST/PCI, Family 12h/14h Processor Function 7
:(4130:5910:0:0) pci, None, HOST/PCI, Family 12h/14h Processor Function 5
:(4130:5889:0:0) pci, None, HOST/PCI, Family 12h/14h Processor Function 1
:(4130:5888:0:0) pci, None, HOST/PCI, Family 12h/14h Processor Function 0
:(4130:5891:0:0) pci, k10temp, HOST/PCI, Family 12h/14h Processor Function 3
:(4130:5890:0:0) pci, None, HOST/PCI, Family 12h/14h Processor Function 2
:(5772:50:4187:57415) pci, ath9k, NETWORK, AR9485 Wireless Network Adapter
:(4098:17312:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 0)
:(4098:17314:4098:0) pci, pcieport, PCI/PCI, N/A
:(4098:17315:4098:0) pci, pcieport, PCI/PCI, N/A
:(4098:17285:4133:1432) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17309:4133:1432) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:4133:1432) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(6505:8290:4133:1432) pci, atl1c, ETHERNET, AR8152 v2.0 Fast Ethernet
:(4098:17302:4133:1432) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4133:1432) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:4133:1432) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4133:1432) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:
:
:Informacje o systemie plików
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 12901535 11834272 11703251 3276800 3144160 3144160
:/dev/sda2 /boot ext4 1024 1024 495844 436374 410774 128016 127787 127787
:/dev/sda5 /home ext4 4096 4096 62481117 62203684 59029809 15876096 15872374 15872374
:
Comment 1 Josh Boyer 2012-04-18 13:33:27 EDT
You might want to try 3.3.2 and see if it is any better.
Comment 2 Mohammed Shafi 2012-04-19 00:49:56 EDT
looks like the same bug with AR9485 in
https://bugzilla.redhat.com/show_bug.cgi?id=811142
Comment 3 Emilia S. 2012-04-19 12:20:49 EDT
@ Josh Boyer
I did try 3.3.2 it was worse - wifi tried to turned on the startup and CPU got stuck before system fully started.
@ Mohammed Shafi
I see it's assigned to the same person. You're right - it's probably double (I reported this bug by a system tool, probably it didn't check the bugs well enough). But perhaps the information in this bug will help John W. Linville so I'll let him decide if it's a double.
Thanks anyway :)
Comment 4 Josh Boyer 2012-09-18 11:30:24 EDT

*** This bug has been marked as a duplicate of bug 811142 ***

Note You need to log in before you can comment on or make changes to this bug.