Bug 813899 - [abrt] kernel: WARNING: at drivers/base/firmware_class.c:538 _request_firmware+0x488/0x4d0()
[abrt] kernel: WARNING: at drivers/base/firmware_class.c:538 _request_firmwar...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mauro Carvalho Chehab
Fedora Extras Quality Assurance
abrt_hash:538833e61cea15da889d7c65028...
:
: 813900 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 13:40 EDT by Jaroslav Škarvada
Modified: 2013-07-04 18:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 16:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (99.95 KB, text/plain)
2012-04-23 12:26 EDT, Jaroslav Škarvada
no flags Details
dmesg with firmware in place (79.15 KB, text/plain)
2012-04-26 03:08 EDT, Jaroslav Škarvada
no flags Details

  None (edit)
Description Jaroslav Škarvada 2012-04-18 13:40:56 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        initrd=initrd0.img root=live:CDLABEL=PM-Test-Day-LiveCD rootfstype=auto ro liveimg quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
comment:        Hibernate was invoked.
kernel:         3.3.0-1.fc17.x86_64
reason:         WARNING: at drivers/base/firmware_class.c:538 _request_firmware+0x488/0x4d0()
time:           Wed 18 Apr 2012 03:32:47 PM EDT

backtrace:
:WARNING: at drivers/base/firmware_class.c:538 _request_firmware+0x488/0x4d0()
:Hardware name: M56S-S3
:Modules linked in: binfmt_misc fuse ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack bnep bluetooth rfkill saa7134_alsa mt352 saa7134_dvb videobuf_dvb dvb_core tuner_xc2028 tuner snd_hda_codec_realtek rc_avermedia_a16d snd_hda_intel saa7134 snd_hda_codec snd_hwdep tveeprom videobuf_dma_sg ir_lirc_codec lirc_dev snd_pcm videobuf_core ir_mce_kbd_decoder v4l2_common snd_page_alloc ir_sanyo_decoder videodev ir_sony_decoder snd_timer ir_jvc_decoder v4l2_compat_ioctl32 snd ir_rc6_decoder ir_rc5_decoder media ppdev ir_nec_decoder microcode soundcore edac_core rc_core forcedeth parport_pc edac_mce_amd k8temp serio_raw i2c_nforce2 parport uinput squashfs ata_generic pata_acpi firewire_ohci firewire_core crc_itu_t pata_amd usb_storage nouveau mxm_wmi wmi video drm_kms_helper ttm drm i2c
:_core [last unloaded: scsi_wait_scan]
:Pid: 2116, comm: kworker/u:18 Tainted: G        W    3.3.0-1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105695f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff810569ba>] warn_slowpath_null+0x1a/0x20
: [<ffffffff813ab958>] _request_firmware+0x488/0x4d0
: [<ffffffff813aba36>] request_firmware+0x16/0x20
: [<ffffffffa0361345>] generic_set_freq+0xc55/0x1a20 [tuner_xc2028]
: [<ffffffffa0001424>] ? i2c_smbus_xfer+0x104/0x120 [i2c_core]
: [<ffffffffa0001a8b>] ? i2c_default_probe+0xeb/0x130 [i2c_core]
: [<ffffffffa00005db>] ? i2c_check_addr_busy+0x3b/0x60 [i2c_core]
: [<ffffffffa000279d>] ? i2c_new_probed_device+0xcd/0x140 [i2c_core]
: [<ffffffffa00019a0>] ? i2c_smbus_read_byte+0x70/0x70 [i2c_core]
: [<ffffffff8116c5e1>] ? __kmalloc_track_caller+0x51/0x180
: [<ffffffffa03621b1>] xc2028_set_analog_freq+0xa1/0x220 [tuner_xc2028]
: [<ffffffffa03574fe>] fe_set_params+0x1e/0x50 [tuner]
: [<ffffffffa0357b62>] set_tv_freq+0xc2/0x200 [tuner]
: [<ffffffffa0357ccb>] set_freq+0x2b/0x50 [tuner]
: [<ffffffffa0358021>] tuner_s_std+0x131/0x310 [tuner]
: [<ffffffffa02f1591>] saa7134_set_tvnorm_hw+0x2b1/0x3d0 [saa7134]
: [<ffffffffa02e97df>] saa7134_resume+0xff/0x1d0 [saa7134]
: [<ffffffff812e38d1>] pci_legacy_resume+0x41/0x60
: [<ffffffff812e4740>] pci_pm_resume+0x90/0xd0
: [<ffffffff812e46b0>] ? pci_pm_restore+0xd0/0xd0
: [<ffffffff813a57b8>] dpm_run_callback+0x58/0x90
: [<ffffffff813a5bea>] device_resume+0x10a/0x240
: [<ffffffff813a5d41>] async_resume+0x21/0x50
: [<ffffffff8107fce3>] async_run_entry_fn+0x83/0x160
: [<ffffffff81071a79>] process_one_work+0x129/0x3f0
: [<ffffffff8107fc60>] ? async_schedule+0x20/0x20
: [<ffffffff810732b6>] worker_thread+0x126/0x2d0
: [<ffffffff81073190>] ? manage_workers.isra.25+0x1f0/0x1f0
: [<ffffffff81078763>] kthread+0x93/0xa0
: [<ffffffff815f47a4>] kernel_thread_helper+0x4/0x10
: [<ffffffff810786d0>] ? flush_kthread_worker+0x80/0x80
: [<ffffffff815f47a0>] ? gs_change+0x13/0x13

smolt_data:
:
:
:General
:=================================
:UUID: 68617d1c-732e-498b-891a-1992d9589adb
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6428.80
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) 64 X2 Dual Core Processor 6400+
:CPU Stepping: 3
:CPU Family: 15
:CPU Model Num: 67
:Number of CPUs: 2
:CPU Speed: 3200
:System Memory: 7986
:System Swap: 0
:Vendor: Gigabyte Technology Co., Ltd.
:System: M56S-S3 
:Form factor: Desktop
:Kernel: 3.3.0-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:1097:5208:623) pci, None, PCI/PCI, MCP65 PCI bridge
:(4318:1104:5208:57344) pci, forcedeth, ETHERNET, MCP65 Ethernet
:(4318:1112:4318:0) pci, pcieport, PCI/PCI, MCP65 PCI Express bridge
:(4318:1096:5208:20482) pci, pata_amd, STORAGE, MCP65 IDE
:(4318:1108:5208:20484) pci, ohci_hcd, USB, MCP65 USB Controller
:(4318:1109:5208:20484) pci, ehci_hcd, USB, MCP65 USB Controller
:(4401:28979:5217:63798) pci, saa7134, MULTIMEDIA, Hybrid+FM PCI (rev A16D)
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4318:1117:5208:45058) pci, ahci, STORAGE, MCP65 SATA Controller
:(4172:32804:5208:4096) pci, firewire_ohci, FIREWIRE, GA-EP45-DS5 Motherboard
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4318:1098:5208:40962) pci, snd_hda_intel, MULTIMEDIA, MCP65 High Definition Audio
:(4318:1553:5208:13426) pci, nouveau, VIDEO, G92 [GeForce 8800 GT]
:(4318:1092:5208:20481) pci, None, RAM, MCP65 Memory Controller
:(4318:1093:5208:3089) pci, None, RAM, MCP65 Memory Controller
:(4318:1094:5208:3089) pci, nForce2_smbus, SERIAL, MCP65 SMBus
:(4318:1089:5208:3089) pci, None, PCI/ISA, MCP65 LPC Bridge
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sr0 WITHHELD iso9660 2048 2048 350140 0 0 0 0 0
:/dev/mapper/live-rw / ext4 4096 4096 1045750 397751 387267 262144 154338 154338
:
Comment 1 Mauro Carvalho Chehab 2012-04-20 14:52:46 EDT
Could you provide the entire dmesg? It seems that the xc3028 firmware is taking a long time to load. Do you have it installed on your machine?
Comment 2 Jaroslav Škarvada 2012-04-23 03:33:36 EDT
Thanks for response, I will get to the affected machine today and try to grab the dmesg.

It was F17 livecd, thus (IMHO) the xc3028 firmware was not there. The abrt dialog pop-ups only after resume from suspend, thus I think it shouldn't do that even without the firmware (i.e. it is silent after boot, but complains after resume, maybe abrt bug).
Comment 3 Jaroslav Škarvada 2012-04-23 03:35:02 EDT
(In reply to comment #2)
> dialog pop-ups only after resume from suspend
It was resume from hibernate.
Comment 4 Jaroslav Škarvada 2012-04-23 12:26:28 EDT
Created attachment 579629 [details]
dmesg
Comment 5 Mauro Carvalho Chehab 2012-04-23 13:25:44 EDT
(In reply to comment #2)
> Thanks for response, I will get to the affected machine today and try to grab
> the dmesg.
> 
> It was F17 livecd, thus (IMHO) the xc3028 firmware was not there. 

Yes, there's no firmware there:

[   57.163238] xc2028 5-0061: Error: firmware xc3028-v27.fw not found.

It would be interesting if you could get the firmware and store it at /lib/firmware. 

We were never being able of getting the rights to distribute this firmware. Due to that, Fedora won't install it.

In order to install them, you'll need to run a script, found at the Kernel's
Documentation/video4linux/extract_xc3028.pl. The instructions on how to use it is commented there. In your case, you only need the xc3028-v27.fw firmware.

> The abrt
> dialog pop-ups only after resume from suspend, thus I think it shouldn't do
> that even without the firmware (i.e. it is silent after boot, but complains
> after resume, maybe abrt bug).

Maybe there's some lock issue either at tuner-xc2028 or at saa7134 driver. It may just be some bad unlock at the error path, or something that would actually affect someone using the driver. Testing it with a real firmware would help us to better understand where to look inside the driver's codes.
Comment 6 Jaroslav Škarvada 2012-04-24 03:58:34 EDT
(In reply to comment #5)
> It would be interesting if you could get the firmware and store it at
> /lib/firmware. 
> 
No problem, I will try to test it (probably today).

> > The abrt
> > dialog pop-ups only after resume from suspend, thus I think it shouldn't do
> > that even without the firmware (i.e. it is silent after boot, but complains
> > after resume, maybe abrt bug).
> 
> Maybe there's some lock issue either at tuner-xc2028 or at saa7134 driver. It
> may just be some bad unlock at the error path, or something that would actually
> affect someone using the driver. Testing it with a real firmware would help us
> to better understand where to look inside the driver's codes.
>
I will provide more info, thanks for looking on this.
Comment 7 Jaroslav Škarvada 2012-04-26 03:08:42 EDT
Created attachment 580382 [details]
dmesg with firmware in place
Comment 8 Jaroslav Škarvada 2012-04-26 03:21:16 EDT
The backtrace seems the same, no idea why. I will retest again later.

# ls -l /lib/firmware | grep xc3028
-rw-r--r--. 1 root root   66220 Aug 11  2008 xc3028-v27.fw
Comment 9 Josh Boyer 2012-04-26 09:31:57 EDT
*** Bug 813900 has been marked as a duplicate of this bug. ***
Comment 10 Jaroslav Škarvada 2012-05-14 16:01:02 EDT
I retried with newer live image and it seems the problem gone, closing.

Note You need to log in before you can comment on or make changes to this bug.