Bug 813924 - key activation on instance launch parameter is messed up
key activation on instance launch parameter is messed up
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matt Wagner
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 15:04 EDT by dgao
Modified: 2012-05-15 18:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:59:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one_letter_no_activation (198.78 KB, image/png)
2012-04-18 15:04 EDT, dgao
no flags Details
two_letter_activation (208.90 KB, image/png)
2012-04-18 15:05 EDT, dgao
no flags Details
no_letter_activation (205.64 KB, image/png)
2012-04-18 15:05 EDT, dgao
no flags Details

  None (edit)
Description dgao 2012-04-18 15:04:50 EDT
Created attachment 578442 [details]
one_letter_no_activation

The event that detects user inputs is behaving improperly for the instance launch-time parameter fields.

By entering a single character for the parameter value, the "Finalize" button stays grayed out. (In screenshot)

By entering two characters for the parameter value, the "Finalize" button activates. (In screenshot)

Then by removing the two character from the parameter values, the "Finalize" button stays activated. (In screenshot)

In addition, pasting a value into the parameter field also does not activate the "Finalize" button.
Comment 1 dgao 2012-04-18 15:05:14 EDT
Created attachment 578443 [details]
two_letter_activation
Comment 2 dgao 2012-04-18 15:05:32 EDT
Created attachment 578444 [details]
no_letter_activation
Comment 3 dgao 2012-04-18 15:06:42 EDT
[root@qeblade30 ~]# rpm -qa | grep "aeolus"
aeolus-conductor-doc-0.8.10-1.el6_2.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.10-1.el6_2.noarch
aeolus-conductor-daemons-0.8.10-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
aeolus-conductor-0.8.10-1.el6_2.noarch
Comment 5 Matt Wagner 2012-04-18 17:01:12 EDT
Pushed f94a89a84fe53770f2e708c60728d11f589cb124 to master.
Comment 7 Matt Wagner 2012-04-18 17:35:29 EDT
And on 1.0-product, e451adcde460142fc823b81b5b0c39b49aecc18d
Comment 8 wes hayutin 2012-04-19 20:30:21 EDT
This is working afaict.. I'll move this to verified tomorrow.
Comment 9 wes hayutin 2012-04-26 15:52:24 EDT
(In reply to comment #0)
> Created attachment 578442 [details]
> one_letter_no_activation
> 
> The event that detects user inputs is behaving improperly for the instance
> launch-time parameter fields.
> 
> By entering a single character for the parameter value, the "Finalize" button
> stays grayed out. (In screenshot)

fixed

> 
> By entering two characters for the parameter value, the "Finalize" button
> activates. (In screenshot)

same.. working
> 
> Then by removing the two character from the parameter values, the "Finalize"
> button stays activated. (In screenshot)

fixed 
> 
> In addition, pasting a value into the parameter field also does not activate
> the "Finalize" button.

paste fixed


[root@qeblade30 ~]# rpm -qa | grep aeolus
aeolus-configure-2.5.3-1.el6.noarch
aeolus-conductor-0.8.13-1.el6_2.noarch
aeolus-all-0.8.13-1.el6_2.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.13-1.el6_2.noarch
aeolus-conductor-doc-0.8.13-1.el6_2.noarch
[root@qeblade30 ~]#
Comment 10 errata-xmlrpc 2012-05-15 18:59:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.