Bug 813957 - dovecot proxy SSL connection requires CRLs
Summary: dovecot proxy SSL connection requires CRLs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dovecot
Version: 6.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks: 836160 1229298
TreeView+ depends on / blocked
 
Reported: 2012-04-18 20:50 UTC by Orion Poplawski
Modified: 2015-07-22 06:57 UTC (History)
4 users (show)

Fixed In Version: dovecot-2.0.9-17.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, dovecot logged a redundant "unable to get certificate" error message when no certification revocation list (CRL) was available. With this update, dovecot no longer treats missing CRL as an error, and no longer logs an error in the mentioned scenario.
Clone Of:
: 1124783 1229298 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:57:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1348 normal SHIPPED_LIVE dovecot bug fix and enhancement update 2015-07-20 17:59:48 UTC

Description Orion Poplawski 2012-04-18 20:50:05 UTC
Description of problem:

dovecot proxy SSL connection requires certificate CRLs:

Apr 18 14:21:40 hawk dovecot: imap-login: Invalid certificate: unable to get certificate CRL: /O=mail.cora.nwra.com/OU=Domain Control Validated/CN=mail.cora.nwra.com
Apr 18 14:21:40 hawk dovecot: imap-login: Invalid certificate: unable to get certificate CRL: /C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./OU=http://certificates.godaddy.com/repository/CN=Go Daddy Secure Certification Authority/serialNumber=07969287
Apr 18 14:21:40 hawk dovecot: imap-login: Invalid certificate: unable to get certificate CRL: /C=US/O=The Go Daddy Group, Inc./OU=Go Daddy Class 2 Certification Authority
Apr 18 14:21:40 hawk dovecot: imap-login: Invalid certificate: unable to get certificate CRL: /L=ValiCert Validation Network/O=ValiCert, Inc./OU=ValiCert Class 2 Policy Validation Authority/CN=http://www.valicert.com//emailAddress=info@valicert.com

This has been fixed in recent releases with this patch:

http://dovecot.org/list/dovecot-cvs/2011-November/019379.html

Version-Release number of selected component (if applicable):
dovecot-2.0.9-2.el6_1.1.i686

How reproducible:
everytime

Steps to Reproduce:
1. Enable auth-static.conf.ext in 10-auth.conf
2. Set something like:

passdb {
  driver = static
  args = proxy=y host=mail.example.com nopassword=y ssl=y
}

3. Connect to proxy
  
Actual results:
Connection fails

Expected results:
Connection works

Comment 1 Orion Poplawski 2012-04-18 20:51:14 UTC
I should note that the patch is in the current dovecot releases.

Comment 6 errata-xmlrpc 2015-07-22 06:57:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1348.html


Note You need to log in before you can comment on or make changes to this bug.