Bug 813971 - Ctrl+Space activates ibus regardless of setting in ibus-setup
Ctrl+Space activates ibus regardless of setting in ibus-setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 17:46 EDT by Matt Chan
Modified: 2012-05-10 10:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-1.4.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 10:25:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of ibus-setup window (40.54 KB, image/png)
2012-04-19 08:35 EDT, Matt Chan
no flags Details

  None (edit)
Description Matt Chan 2012-04-18 17:46:37 EDT
Description of problem:
I removed the Ctrl+Space shortcut in ibus-setup and changed it to Alt + Shift. This works well, except ibus still activates when I use the Ctrl+Space shortcut.

Version-Release number of selected component (if applicable):
16

How reproducible:
Always?

Steps to Reproduce:
1. Clear all keyboard shortcuts in ibus-setup
2. Press Ctrl + Space
3. 
  
Actual results:
Ibus switches the input method

Expected results:
Ibus should do nothing.

Additional info:
I am using Anthy.
Comment 1 fujiwara 2012-04-19 00:17:51 EDT
I cannot reproduce your problem.
Could you attach the screenshot of ibus-setup in this bug report?
% gnome-screenshot --delay 5 --window

I guess you just removed Control+Space in trigger key but it would not work. You need to add another trigger key likes Alt+Shift but not just remove the trigger and also you need to restart ibus-daemon.
Comment 2 Matt Chan 2012-04-19 08:35:42 EDT
Created attachment 578631 [details]
screenshot of ibus-setup window
Comment 3 Matt Chan 2012-04-19 08:38:15 EDT
I've had this configuration for several months, but I just discovered the ctrl+space shortcut wasn't disabled. Ibus-daemon should have restarted when I shutdown etc I think.

"You need to add another trigger key likes Alt+Shift but not just remove the
trigger" Is there a reason that removing the shortcut key by itself doesn't work?
Comment 4 fujiwara 2012-04-19 23:07:26 EDT
(In reply to comment #2)
> Created attachment 578631 [details]
> screenshot of ibus-setup window

OK, when you also put the "Alt+Shift_L" in "Toggle input methods" text entry, I think Control+Space is disabled.
Currently the null entry fall back to "Control+Space".

Probably this would be a low priority since above way could resolve your problem and this problem is fixed in Fedora 17.
Comment 5 Matt Chan 2012-04-19 23:16:35 EDT
Oh ok, as long as it's fixed in F17.

Thanks for your help,
Matt
Comment 6 fujiwara 2012-04-24 06:02:53 EDT
--- ibus-1.4.1/bus/ibusimpl.c.orig	2012-04-24 11:24:08.599011751 +0900
+++ ibus-1.4.1/bus/ibusimpl.c	2012-04-24 11:43:20.116830546 +0900
@@ -1480,19 +1480,16 @@ _get_engine_desc_hotkeys_with_system (IB
 
     /* If the user customized the trigger key, the trigger key is used for
      * any IBus engines. */
-    if (_bridge_trigger_keys != NULL &&
-        *_bridge_trigger_keys != '\0' &&
-        g_strcmp0 (_bridge_trigger_keys, "Control+space") != 0) {
-
+    if (g_strcmp0 (_bridge_trigger_keys, "Control+space") != 0) {
         hotkeys = (const gchar *) _bridge_trigger_keys;
     } else if (desc) {
         hotkeys = ibus_engine_desc_get_hotkeys (desc);
-    }
 
-    /* If engine hotkeys are not defined in the compose xml file,
-     * IBus trigger keys are used. */
-    if (!hotkeys || !*hotkeys) {
+        /* If engine hotkeys are not defined in the compose xml file,
+         * IBus trigger keys are used. */
+        if (!hotkeys || !*hotkeys) {
             hotkeys = (const gchar *) _bridge_trigger_keys;
+        }
     }
 
     return hotkeys;
@@ -3026,26 +3023,21 @@ _add_engine_hotkey (IBusEngineDesc *engi
 
     /* If the user customized the trigger key, the trigger key is used for
      * any IBus engines. */
-    if (_bridge_trigger_keys != NULL &&
-        *_bridge_trigger_keys != '\0' &&
-        g_strcmp0 (_bridge_trigger_keys, "Control+space") != 0) {
-
+    if (g_strcmp0 (_bridge_trigger_keys, "Control+space") != 0) {
         hotkeys = (const gchar *) _bridge_trigger_keys;
     } else {
         hotkeys = ibus_engine_desc_get_hotkeys (engine);
+
+        /* If engine hotkeys are not defined in the compose xml file,
+         * IBus trigger keys are used. */
+        if (!hotkeys || !*hotkeys) {
+            hotkeys = (const gchar *) _bridge_trigger_keys;
+        }
     }
 #else
     hotkeys = ibus_engine_desc_get_hotkeys (engine);
 #endif
 
-#if USE_BRIDGE_HOTKEY
-    /* If engine hotkeys are not defined in the compose xml file, IBus trigger
-     * keys are used. */
-    if (!hotkeys || !*hotkeys) {
-        hotkeys = (const gchar *) _bridge_trigger_keys;
-    }
-#endif
-
     if (!hotkeys || !*hotkeys) {
         return;
     }
Comment 7 Fedora Update System 2012-04-28 04:01:05 EDT
ibus-1.4.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.4.1-2.fc16
Comment 8 Fedora Update System 2012-04-28 04:01:21 EDT
ibus-1.4.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.4.1-2.fc15
Comment 9 Fedora Update System 2012-04-28 20:21:46 EDT
Package ibus-1.4.1-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.1-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6902/ibus-1.4.1-2.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-05-10 10:25:41 EDT
ibus-1.4.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-05-10 10:32:10 EDT
ibus-1.4.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.