Bug 814043 - remote-viewer does not have an application name set for human friendly title bar
remote-viewer does not have an application name set for human friendly title bar
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 02:01 EDT by Geyang Kong
Modified: 2013-08-04 23:43 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-6.el6
Doc Type: Bug Fix
Doc Text:
None required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:12:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geyang Kong 2012-04-19 02:01:16 EDT
Description of problem:
  virt-viewer doesn't open console form with specific name.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-5.el6.x86_64

How reproducible:
100%

Steps to Reproduce:

1. Make sure there is a running guest.

2. Run #virt-viewer --name=test $guest

Actual results:

1. Console form opened without specific name.

Expected results:

1. Name of console form should be "test".

Additional info:

1. If I use remote-viewer --name=test spice://127.0.0.1:5900, it will be OK.
Comment 1 Daniel Berrange 2012-04-19 04:48:30 EDT
I don't really understand what you're expecting to happen here. The '--name' option is a low level setting only ever used by legacy Window Managers and is not something you ever really want to set these days.
Comment 2 Geyang Kong 2012-04-20 06:11:45 EDT
I reported this bug because of I can get the --name option from #virt-viewer --help-all command. And it works well in remote-viewer command, so I think it should do same thing in virt-viewer.
Comment 3 Daniel Berrange 2012-04-23 06:10:27 EDT
So in GLib there are two names maintained

 - program name - this is a named based on the 'argv[0]' of the binary, but overridable using '--name'
 - application name - this is a human friendly name, set by the application author

The window title bars will include the application name, but if that is not set, they fallback to using the program name. The remote viewer program had forgotten to set the application name, so we were falling back to program name. This is why the --name argument was able to affect the window title., Once we fix remote viewer to have an applicaiton name set, the title bar will *not* be affected by the --name argument, and thus behave the same as virt-viewer does.
Comment 4 Daniel Berrange 2012-04-23 06:11:22 EDT
Fix upstream

https://www.redhat.com/archives/virt-tools-list/2012-April/msg00104.html
Comment 5 Daniel Berrange 2012-04-23 13:07:19 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
None required
Comment 7 Geyang Kong 2012-04-24 04:44:28 EDT
Verified pass on the build
virt-viewer-0.5.2-6.el6.x86_64

Reproduced steps:
1. Have a running guest.
2. run #remote-viewer --name=test spice://127.0.0.1:5900
3. run #remote-viewer --name=test vnc://127.0.0.1:5900
4. run #virt-viewer --name=test $guestname

Actual result:
1. virt-viewer or remote-viewer form can be opened without any "name".

Change this bug to VERIFIED.
Comment 9 errata-xmlrpc 2012-06-20 08:12:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0772.html

Note You need to log in before you can comment on or make changes to this bug.