This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 814056 - sync() can't work and will hang up
sync() can't work and will hang up
Status: CLOSED DUPLICATE of bug 812588
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 02:59 EDT by Zhouping Liu
Modified: 2014-01-12 19:01 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 03:38:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zhouping Liu 2012-04-19 02:59:28 EDT
Description of problem:
when I did ltp test, there were some cases  blocked, at least I found sync() make the mistakes, and also it couldn't use 'Ctrl-C' or 'kill -9' to kill the process.

Version-Release number of selected component (if applicable):
[zliu@ZhoupingLiu mtest06]$ uname -ri
3.3.2-1.fc17.x86_64 x86_64
[zliu@ZhoupingLiu mtest06]$ rpm -q coreutils
coreutils-8.15-6.fc17.x86_6

How reproducible:
100%

Steps to Reproduce:
[zliu@ZhoupingLiu ~]$ cat test.c 
#include <unistd.h>
#include <stdio.h>

int main()
{
	printf("test sync()\n");

	sync();
	return 0;
}
[zliu@ZhoupingLiu zliu]# ./test 
test sync()


^C^C^

as the above, can't endup the process

Or you can directly run sync command to reproduce the issue:
[root@ZhoupingLiu zliu]# sync

^C^C^

Actual results:
the sync hang up

Expected results:
sync work fine

Additional info:
couldn't find the issue in RHEL7 Alpha and RHEL6.
Comment 1 Kamil Dudka 2012-04-19 03:38:11 EDT

*** This bug has been marked as a duplicate of bug 812588 ***

Note You need to log in before you can comment on or make changes to this bug.