Bug 814079 - Move from db4 to db5
Move from db4 to db5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-BDB (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 03:59 EDT by Petr Pisar
Modified: 2012-04-19 05:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-BDB-1.90-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 05:10:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-04-19 03:59:59 EDT
Because of bug #768846, I'd like to see all Perl packages being linked against the same Berkeley database library version.

Currently latest perl-BDB-1.88-5.fc17 links to db4. Please replace `db4-devel' build-require with `libdb-devel'. According my tests, you will need to upgrade perl-BDB to 1.9 (http://cpansearch.perl.org/src/MLEHMANN/BDB-1.9/Changes).
Comment 1 Nicolas Chauvet (kwizart) 2012-04-19 04:13:13 EDT
Thx for the record, please go ahead with the changes update and push to bodhdi.
I will only be able to do this at the end of the day.
Comment 2 Nicolas Chauvet (kwizart) 2012-04-19 04:13:32 EDT
s/record/report/
Comment 3 Petr Pisar 2012-04-19 05:10:22 EDT
I made the changes only in F18 because there is no answer yet whether db5 can handle db4 files properly. The same applies to perl and other packages.

I augmented new perl-BDB version from 1.9 to 1.90 to be higher than older 1.88 because I think remembering epoch number when putting dependencies in other packages is error-prone.

Note You need to log in before you can comment on or make changes to this bug.