Bug 814094 - libvirt starts to require sending keep-alive messages
libvirt starts to require sending keep-alive messages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Novacek
nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 04:37 EDT by Radek Novacek
Modified: 2016-11-30 19:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 07:58:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Novacek 2012-04-19 04:37:49 EDT
libvirt has been rebased in RHEL 6.3 and now it requires to send keep-alive messages. Virt-who doesn't send them (and probably won't in the future because it would mean to implement event loop), so the connection get closed between two messages, so virt-who is getting "Broken pipe" error.

Disabling keep-alive messages is not possible now because of bug #813819.

Virt-who internal mechanism retries the connection to libvirt after the failure and it succeeds, so this mean no harm, just some unnecessary operations. And it breaks waiting for events from libvirt.
Comment 2 Radek Novacek 2012-04-19 07:58:00 EDT
This is bug in invalid. This issue was caused by implementing double-forking in bug #806225. The event loop for interacting with libvirt was created to soon (before the double-fork) and keep-alive messages gets lost somehow. Will be fixed as part of fix in bug #813299, because it's same part of the code.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.