Bug 814113 - thinp chunksize range issue
thinp chunksize range issue
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdenek Kabelac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 05:25 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
13 users (show)

See Also:
Fixed In Version: lvm2-2.02.97-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 01:00:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2012-04-19 05:25:59 EDT
Description of problem:
from the manpage of lvcreate.
>>>snip>>
       -c, --chunksize ChunkSize
              Power of 2 chunk size in sector units (512b).  For snapshot logical volume the value must be between 8 (4KB) and 1024 (512KB) and the default value is 8.  For  thin pool logical volume the value must be between 128 (64KB) and 2097152 (1MB) and the default value is 128.
>>>snip>>>

actually result :
1. wrong chunksize range in the error message
# lvcreate -c 32 -l 2 -T vg/pool1
lvcreate  Chunk size must be a power of 2 in the range 64K to 64K
lvcreate  Run `lvcreate --help' for more information.

2. the max thinp supported chunksize is beyond 1024
# lvcreate -c 2048 -l 10 -T vg/pool3
# lvs -o lv_name,thin_count,chunksize vg/pool3
lvs  LV    #Thi Chunk
lvs  pool3    0 2.00m

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Kabelac 2012-04-19 05:49:57 EDT
Already fixed upstream with man page fix as well.

https://www.redhat.com/archives/lvm-devel/2012-March/msg00085.html
Comment 2 Xiaowei Li 2012-09-03 05:56:20 EDT
verified with lvm2-2.02.97-1.el7.x86_64
Comment 3 Xiaowei Li 2012-11-14 06:28:56 EST
change the 'version' to 18 since it's fixed in F18

Note You need to log in before you can comment on or make changes to this bug.