Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 814156 - help_msg should use argv[0] except of PACKAGE
Summary: help_msg should use argv[0] except of PACKAGE
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-viewer
Version: 17
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-19 10:16 UTC by Lubos Kocman
Modified: 2012-12-14 21:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 814150
Environment:
Last Closed: 2012-12-14 21:17:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Lubos Kocman 2012-04-19 10:16:16 UTC
+++ This bug was initially created as a clone of Bug #814150 +++

Description of problem:

remote-viewer and virt-viewer are both using following constant for the usage print

const char *help_msg = N_("Run '" PACKAGE " --help' to see a full list of available command line options");

Which leads to:

$ remote-viewer --hfsdafd
Unknown option --hfsdafd
Run 'virt-viewer --help' to see a full list of available command line options

$ virt-viewer --hfsdafd
Unknown option --hfsdafd
Run 'virt-viewer --help' to see a full list of available command line options

printing virt-viewer in both cases



Version-Release number of selected component (if applicable):

(this could be fixed in both fedora and rhel)

How reproducible:


Steps to Reproduce:
1.remote-viewer --hfsdafd

  
Actual results:

Unknown option --hfsdafd
Run 'virt-viewer --help' to see a full list of available command line options


Expected results:

Unknown option --hfsdafd
Run 'remote-viewer --help' to see a full list of available command line options


Additional info:

This is also worth a look

[lkocman@dhcp-29-219 kvm]$ remote-viewer sdfdsaf
Segmentation fault

Comment 1 Cole Robinson 2012-12-14 21:17:13 UTC
The latter issue is fixed in F17 already, but the argv[0] bit persists. However both are fixed in F18, and since it's a minor bit, just closing as NEXTRELEASE


Note You need to log in before you can comment on or make changes to this bug.