Bug 814174 - livecd-iso-to disk throws /usr/bin/livecd-iso-to-disk: line 1092: [: too many arguments error
livecd-iso-to disk throws /usr/bin/livecd-iso-to-disk: line 1092: [: too many...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 06:36 EDT by Abhishek Singh
Modified: 2012-05-08 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: livecd-tools-17.11-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 00:32:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhishek Singh 2012-04-19 06:36:36 EDT
Description of problem:
I'm using livecd-tool package (version 16.11-1.fc16.x86_64) on a Fedora 16 machine. Whenever I use livecd-iso-to-disk with --format --msdos --reset-mbr parameters, I get a "/usr/bin/livecd-iso-to-disk: line 1092: [: too many arguments". But the script continues to work despite the error. The script exits with an exit code of "1".

Version-Release number of selected component (if applicable):
16.11-1

How reproducible:
Every time you run the script with --format --msdos --reset-mbr parameters

Steps to Reproduce:
1. Run livecd-iso-to-disk command with --format --msdos --reset-mbr parameters
  
Actual results:
Throws a "/usr/bin/livecd-iso-to-disk: line 1092: [: too many arguments" and exits with an exit code of 1.

Expected results:
Should not throw that error and should exit with an exit code of 0.

Additional info:
I'm using this on the http://xs-dev.laptop.org/xs/OLPC-School-Server-0.7-i386.iso ISO file and also on the ISO created by myself using pungi.
Comment 1 Brian Lane 2012-04-19 13:23:44 EDT
What is the full commandline that you used? The line in question is:

if [ -e $TGTMNT/$(basename "$SRC") ]; then

I can't reproduce it here.
Comment 2 Abhishek Singh 2012-04-19 23:15:57 EDT
The full commandline I used is:

livecd-iso-to-disk --format --msdos --reset-mbr /sandbox/nexs/OLPC\ School\ Server-0.7-i386.iso /dev/sdb1

The iso in question "OLPC\ School\ Server-0.7-i386.iso" is placed insided /sandbox/nexs directory and "/dev/sdb1" is the single partition on my USB stick of partition type Linux and formatted as vfat. The same problem happens even if it is formatted as ext4.
Comment 3 Abhishek Singh 2012-04-23 02:22:30 EDT
Found the cause of the error. It is because of the blank spaces in the file name of the source ISO file. When I renamed the file and removed spaces, it did work well.

Probably we need to take care for files with blank spaces in its name in the livecd-iso-to-disk script.
Comment 4 Fedora Update System 2012-04-24 18:14:11 EDT
livecd-tools-17.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.9-1.fc17
Comment 5 Fedora Update System 2012-04-25 14:08:17 EDT
livecd-tools-16.13-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.13-1.fc16
Comment 6 Fedora Update System 2012-04-26 15:25:23 EDT
Package livecd-tools-17.9-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-17.9-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6645/livecd-tools-17.9-1.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-04-26 18:09:58 EDT
livecd-tools-17.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.10-1.fc17
Comment 8 Fedora Update System 2012-05-03 19:18:29 EDT
livecd-tools-16.15-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.15-1.fc16
Comment 9 Fedora Update System 2012-05-03 19:34:21 EDT
livecd-tools-17.11-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.11-1.fc17
Comment 10 Fedora Update System 2012-05-08 00:32:30 EDT
livecd-tools-17.11-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.