Bug 814212 - icecast cannot reload configuration
icecast cannot reload configuration
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: icecast (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 07:44 EDT by Petr Pisar
Modified: 2012-12-20 10:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:58:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-04-19 07:44:18 EDT
`systemctl reload icecast.service' refuse to reload configuration because the systemd unit does not define ReloadeExec.

Sending SIGHUP to the daemon does not work either because the daemon is running as icecast:icecast but the configuration file is owned by root:root and permission must be 0640 because the file contains passwords. /etc/icecast.xml should be installed as 0640 file owned by root:icecast.
Comment 1 Fedora Update System 2012-10-15 10:43:35 EDT
icecast-2.3.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/icecast-2.3.3-1.fc18
Comment 2 Fedora Update System 2012-10-15 12:42:37 EDT
icecast-2.3.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/icecast-2.3.3-1.fc17
Comment 3 Fedora Update System 2012-10-15 13:37:51 EDT
Package icecast-2.3.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing icecast-2.3.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16130/icecast-2.3.3-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-12-20 10:58:17 EST
icecast-2.3.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.