Bug 814296 - writev() returns 32-bit wrapped value on ext4 on x86_64 in certain cases
writev() returns 32-bit wrapped value on ext4 on x86_64 in certain cases
Status: CLOSED DUPLICATE of bug 814302
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 10:30 EDT by Jouko Orava
Modified: 2012-04-19 10:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 10:45:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jouko Orava 2012-04-19 10:30:36 EDT
Reported by Jouni Siren to the linux-ext4 mailing list,
http://marc.info/?l=linux-ext4&m=133424246404043&w=2

fixed by a one-line patch to fs/ext4/file.c,
http://marc.info/?l=linux-ext4&m=133424653606040&w=2

verified on 2.6.32-220.7.1.el6.x86_64 kernels,
and verified the patch fixes the problem on said kernels,
http://marc.info/?l=linux-ext4&m=133484292912874&w=2
Comment 2 Eric Sandeen 2012-04-19 10:45:32 EDT

*** This bug has been marked as a duplicate of bug 814302 ***

Note You need to log in before you can comment on or make changes to this bug.