Bug 814365 - Cloning a cloned channel results in improper total errata to clone
Cloning a cloned channel results in improper total errata to clone
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-04-19 13:25 EDT by Stephen Herr
Modified: 2012-11-01 12:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 636816
Environment:
Last Closed: 2012-11-01 12:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2012-04-19 13:25:31 EDT
+++ This bug was initially created as a clone of Bug #636816 +++

Description of problem:
In Satellite 5.2 and 5.3 (possibly in other versions as well), if you have a clone of a cloned channel, the clone of a clone will have already cloned errata listed as available to the channel.

Version-Release number of selected component (if applicable):
Red Hat Network Satellite 530

How reproducible:
Always

Steps to Reproduce:
1.  Clone a Red Hat base channel using the current state of errata
2.  Clone the channel that you created in Step # 1 using the current state of errata
3.  Click Channels-->Manage Software Channels-->Original Cloned Channel-->Errata-->Add-->Add Red Hat Errata-->View Associated Channels-->View Associated Errata...note the number of packages.  This will likely be 0 unless you have since Satellite-synced.
4.  Repeat Step 3, except use the Clone of the Cloned channel.  It will contain thousands of errata.  Or at least a number that is different than the channel it is cloned from
  
Actual results:
The clone of a clone has errata listed that it already owns.

Expected results:
The clone of the clone and the clone itself should have the same errata available to it.

Additional info:

--- Additional comment from sherr@redhat.com on 2012-04-17 08:45:26 EDT ---

When testing I was able to reproduce this issue in Satellite 5.2, but not 5.3 or 5.4. Is there still a desire to get this fixed in 5.2 or has the customer updated to a newer Satellite?

--- Additional comment from tpapaioa@redhat.com on 2012-04-17 12:50:12 EDT ---

I am still able to reproduce this issue on Satellite 5.4.1:

1.) Clone rhel-x86_64-server-5 to clone-rhel-x86_64-server-5, with no errata.

2.) From the channel's Errata > Add > Add Red Hat Errata tab, select a single advisory, e.g.,

RHBA-2007:0110 module-init-tools bug fix update 3/14/07

and click Confirm > Clone Errata.

3.) From the channel's Errata > List/Remove tab, confirm that CLA-2007:0110 is in the channel. Back on Errata > Add > Add Red Hat Errata, confirm that 2,153 errata are listed.

4.) Clone clone-rhel-x86_64-server-5 to clone-clone-rhel-x86_64-server-5, with no errata.

5.) From the channel's Errata > Clone tab, select "Clone as CL-2007:0110" from the Action column for CLA-2007:0110, then click "Clone Errata", then "Update Errata".

6.) From the channel's Errata > List/Remove tab, confirm that the clone-of-a-clone CL-2007:0110 is in the channel. Back on Errata > Add > Add Red Hat Errata, select "Red Hat Enterprise Linux 5" from the Channel Version list, then click "View Associated Channels". Select "Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)" from the Channel list, then click "View Associated Errata". Note that there are 2,154 errata in the list.

The extra advisory in this list, compared to the first channel, is RHBA-2007:0110. This shouldn't be in the list, as CL-2007:0110 already provides the same packages.
Comment 1 Stephen Herr 2012-04-19 13:30:19 EDT
Committed to Spacewalk master: c4d9952ab3adfa5e98bd7ef81d932254b8c3ebe5
Comment 2 Jan Pazdziora 2012-04-20 01:52:14 EDT
Checkstyle fix: 1f5cb0f606376ae695febde7992c80ca2da0143e.
Comment 3 Tomas Lestach 2012-07-19 10:45:22 EDT
reverting these two commits due to performance regression (more info Bug 839611)

spacewalk.git:
 0e98420b34d7d1cb23206842a5959feace5c966f
 545b3494a6e3c26c328ce924c4a709791b797021

The Bug was most probably fixed by previous commits and we wasn't able to reproduce it.

A minor fix - to pre-select correct channel version ...

spacewalk.git:
 808796ccdf5fb3dc262364a9099c1300d0547f4b
 4682414d955c0530295c7fef7c6c686057efd761
Comment 4 Jan Pazdziora 2012-10-30 15:24:20 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 5 Jan Pazdziora 2012-11-01 12:19:36 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.