Bug 814380 - Add skip_broken=1 to yum.conf by default
Add skip_broken=1 to yum.conf by default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 14:01 EDT by Heiko Adams
Modified: 2014-01-21 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 12:19:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2012-04-19 14:01:15 EDT
Description of problem:
Yum has the ability to exclude broken packages from updates since several version but to use this feature you've to add the --skip-broken parameter everytime you run "yum update" or add "skip_broken=1" to your yum.conf.

It would be a good idea to add the "skip_broken=1" line by default to the yum.conf to make yum exclude broken packages from updates by default and without user interaction.

Version-Release number of selected component (if applicable):
yum-3.4.3-23.fc17.noarch

How reproducible:
allways
  
Actual results:
yum aborts updates if one or more packages have dependency problems

Expected results:
yum should exclude packages with dependency problems and contiune update process and update all packages without dependency problems

Additional info:
Comment 1 James Antill 2012-04-20 12:19:37 EDT
 Maybe when we get a new depsolver, we can look at this again. But atm. skip-broken doesn't work well enough to enable it for everyone.

 There's also the fact that it's _much_ better if you are using repos. that aren't broken, instead of relying on skip-broken.

Note You need to log in before you can comment on or make changes to this bug.