Bug 81439 - X crashes after NVidia driver update
X crashes after NVidia driver update
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-09 10:21 EST by Sal Cirabisi
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sal Cirabisi 2003-01-09 10:21:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
My pertinent system info: AMD1400 t-bird; 512mb RAM; NVIDIA GeForce 2 MX 400 
video card; Gateway 1510 monitor



After initial install in which X works but needs a driver update for video to 
work properly. I tried to intall both NVIDIA_kernel and NVIDIA_GLX, versions 
4190 and 3123, to no avail. X crashes and will try to reconfigure itself to no 
avail also. Not sure if this is an XFree issue or a kernel issue???

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Logout of X and run Command "init 3" to shutdown X.  
2. "Tar" NVIDIA drivers. Got to tar'd directories and run "make" and "make 
install":works fine. Drivers install okay. 
3. Run "lsmod" to ensure new "nvidia" driver loaded: it did every time.
4. Change driver data from "nv" to "nvidia" in /etc/X11/XF86Config-4
5. Run "init 5" and X tries to load but fails.
6. Review /var/log/XF86Free0.log and there is NO error/warning to indicate why 
driver will not install.
    

Actual Results:  Crash

Expected Results:  Crash

Additional info:
Comment 1 Sal Cirabisi 2003-01-09 13:32:01 EST
Followup: I tried one more time to load the drivers. I did two things 
differnetly though. 1. I changed the /etc/X11/XF86Config (not the -4 file) and 
2. ran "depmod -a". Rebooted and guess what? Version 4191 loaded!

I will rename XF86Config-4 to see if it was the depmod that did it or not.

 
Comment 2 Mike A. Harris 2003-01-09 18:19:55 EST

*** This bug has been marked as a duplicate of 73733 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.