Bug 81453 - (SOUND I810_AUDIO)No Sound on IBM X30 with Intel 82801CA/CAM AC'97
Summary: (SOUND I810_AUDIO)No Sound on IBM X30 with Intel 82801CA/CAM AC'97
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-09 17:19 UTC by Ed Zarecor
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 20:21:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod output (1.31 KB, text/plain)
2003-01-09 17:21 UTC, Ed Zarecor
no flags Details
modules.conf file (337 bytes, text/plain)
2003-01-09 18:18 UTC, Ed Zarecor
no flags Details
messages chatter related to sound service (1.74 KB, text/plain)
2003-01-09 21:27 UTC, Ed Zarecor
no flags Details

Description Ed Zarecor 2003-01-09 17:19:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I'm unable to play sound on my IBM X30 laptop with Intel 82801CA/CAM AC'97.  CD,
XMMS and sound config all fail to play.  This is true with the following kernels:

2.4.18-14
2.4.18-18.8.0
2.4.18-19.8.0

I'm seeing the following lines in messages:

Jan  9 10:24:05 localhost modprobe: modprobe: Can't locate module sound-slot-1
Jan  9 10:24:05 localhost modprobe: modprobe: Can't locate module
sound-service-1-0

Found similar text in the following bug:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=76580

However, my problem was not fixed by that errata and I have different hardware.

Have attached lsmod output.

Ed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot machine
2.attempt to play sound
3.read error messages, hear nothing
    

Actual Results:  machine has no sound playing capabilities, no cd, no xmms,
alerts, to gaim sounds, etc.

Expected Results:  sound

Additional info:

Comment 1 Ed Zarecor 2003-01-09 17:21:07 UTC
Created attachment 89245 [details]
lsmod output

Comment 2 Arjan van de Ven 2003-01-09 18:09:27 UTC
can you also attach your /etc/modules.conf file ?

Comment 3 Ed Zarecor 2003-01-09 18:18:33 UTC
Created attachment 89250 [details]
modules.conf file

Comment 4 Arjan van de Ven 2003-01-09 18:23:10 UTC
ok this is weird; your xmms seems to ask for:
module sound-slot-1
but your sound card is actually
module sound-slot-0

Bill: any ideas?

Comment 5 Bill Nottingham 2003-01-09 20:40:14 UTC
Do you have any USB devices attached?

Are there any errors from the sound driver aside from the ones about
sound-slot-1? Do those errors correspond *exactly* with trying to play a sound?

What output plugin are you using in xmms?

Comment 6 Ed Zarecor 2003-01-09 21:27:02 UTC
Created attachment 89256 [details]
messages chatter related to sound service

Here's some portion of my messages file related to the sound services.	There's
the one timeout message that may be the culprit.  This occured while trying,
unsuccessfully, to play a CD.  

This problem isn't XMMS specific, the CD player and sound-config also fail to
play sound.  

I have the stock redhat xmms packages, plus the mp3 codec RPM's from here:
http://staff.xmms.org/priv/redhat8/.

Comment 7 Bill Nottingham 2003-01-09 21:44:47 UTC
Ok, that does look like a driver issue.

Comment 8 Ed Zarecor 2003-01-16 16:11:36 UTC
Not sure what the status of this bug is at this point.  Hasn't been any activity
since it was reassigned.  Is there any additional information required?  Is the
bug still in an active queue?

Comment 9 Alan Cox 2003-06-10 17:53:57 UTC
Its still in the pile, but its not something I have a sensible answer too right
now. I'm baffled why it is trying to use /dev/dsp1 unless XMMS has been set
specifically that way by you. DO other apps produce audio ok ?



Note You need to log in before you can comment on or make changes to this bug.