Bug 814584 - Please add org.eclipse.cdt.core.testplugin to eclipse-cdt-sdk
Please add org.eclipse.cdt.core.testplugin to eclipse-cdt-sdk
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 03:21 EDT by Alexander Kurtakov
Modified: 2012-04-25 01:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: eclipse-cdt-8.1.0-0.5.junom6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 01:08:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kurtakov 2012-04-20 03:21:17 EDT
org.eclipse.cdt.core.testplugin seems to be widely used by Linux Tools project tests and installing it from other p2 repos leads to a number of other cdt bundles being installed duplicating/conflicting the system ones. Also there is /usr/lib64/eclipse/dropins/cdt-sdk/eclipse/plugins/org.eclipse.linuxtools.cdt.autotools.core.source_2.0.0.201203191015.jar which is weird as there is no org.eclipse.linuxtools.cdt.autotools.core bundle.
Comment 1 Jeff Johnston 2012-04-20 16:11:50 EDT
(In reply to comment #0)
> org.eclipse.cdt.core.testplugin seems to be widely used by Linux Tools project
> tests and installing it from other p2 repos leads to a number of other cdt
> bundles being installed duplicating/conflicting the system ones. Also there is
> /usr/lib64/eclipse/dropins/cdt-sdk/eclipse/plugins/org.eclipse.linuxtools.cdt.autotools.core.source_2.0.0.201203191015.jar
> which is weird as there is no org.eclipse.linuxtools.cdt.autotools.core bundle.

I can add the snaphot jar asis created in the build for org.eclipse.cdt.core.tests.  I don't think there is any reason to resolve the qualifier as there is no upstream version, but you may have other thoughts.

Regarding the org.eclipse.linuxtools.cdt.autotools.core, this is a compatibility plug-in to allow existing Autotools projects to switch seamlessly to the new plug-ins.  It was not put into any feature upstream so is missing from M6.  The source bundle is referenced by the SDK feature so it got put into the repo both upstream and in the Fedora build.
Comment 2 Alexander Kurtakov 2012-04-20 16:18:15 EDT
It would be really good if we can get org.eclipse.cdt.core.testplugin in. 
About the linuxtools.cdt.autotools.core I wanted to clarify things as it looks suspicious to have source bundle only, glad it's known and fixed.
Comment 3 Fedora Update System 2012-04-20 18:07:28 EDT
eclipse-cdt-8.1.0-0.5.junom6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-cdt-8.1.0-0.5.junom6.fc17
Comment 4 Fedora Update System 2012-04-21 17:06:36 EDT
Package eclipse-cdt-8.1.0-0.5.junom6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-cdt-8.1.0-0.5.junom6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6340/eclipse-cdt-8.1.0-0.5.junom6.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-25 01:08:02 EDT
eclipse-cdt-8.1.0-0.5.junom6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.