Bug 814598 - RFE: Package uwsgi for EPEL
RFE: Package uwsgi for EPEL
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: uwsgi (Show other bugs)
rawhide
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jorge A Gallegos
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 03:52 EDT by Lameire Alexis
Modified: 2015-05-20 00:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: uwsgi-2.0.9-7.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-20 00:52:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lameire Alexis 2012-04-20 03:52:39 EDT
Hi,
I'm user of red hat/centos and i need this package. Can you make a release of it for the epel repository.

Thenks
Alexis Lameire
Comment 1 Jorge A Gallegos 2012-07-08 21:56:44 EDT
Oh shoot, for someone reason this bug totally escaped my mind. So far you're the only one requesting this, I'll see if I can make it work in epel.
Comment 2 Jorge A Gallegos 2012-07-12 01:17:11 EDT
Just to make sure, what version of EPEL are we talking about? el6 should be fairly easy to do, whereas el5 will require some more work/time.
Comment 3 Lameire Alexis 2012-08-04 08:00:02 EDT
I need it to EPEL 6.
Comment 4 0xdeadc0de 2012-09-13 12:55:02 EDT
Ping, could you please add this to EPEL? We also need this on RHEL6.
Comment 5 Fedora End Of Life 2013-01-16 17:54:19 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora End Of Life 2013-02-13 20:25:25 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 7 Guido Berhoerster 2013-02-15 11:18:46 EST
See the following branch for a port of the package to EPEL-6: https://github.com/gber/uwsgi/commits/el-6-port

It depends on a bunch of other improvements and update to 1.4.5 which may or may not be acceptable.
Comment 8 Douglas Mendizábal 2014-06-19 21:18:56 EDT
Any progress on this?  I would very much like to have uwsgi available in epel.
Comment 9 Guido Berhoerster 2014-06-20 06:42:49 EDT
(In reply to Douglas Mendizábal from comment #8)
> Any progress on this?  I would very much like to have uwsgi available in
> epel.

If you're interested, I maintain an copr repo with uwsgi for EPEL at http://copr.fedoraproject.org/coprs/gber/epel-addon/. Unlike the Fedora package it is keep it up to date with the latest upstream stable releases and contains all buildable plugins.
Comment 10 Fedora Update System 2015-03-18 12:26:13 EDT
uwsgi-2.0.9-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1299/uwsgi-2.0.9-3.el6
Comment 11 Fedora Update System 2015-04-24 13:19:40 EDT
uwsgi-2.0.9-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/uwsgi-2.0.9-7.el6
Comment 12 Fedora Update System 2015-04-25 19:52:31 EDT
Package uwsgi-2.0.9-7.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing uwsgi-2.0.9-7.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-6004/uwsgi-2.0.9-7.el6
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2015-05-20 00:52:35 EDT
uwsgi-2.0.9-7.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.