Bug 814625 - dracut Warning: Unable to process initqueue
dracut Warning: Unable to process initqueue
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 05:48 EDT by Frank Murphy
Modified: 2012-12-21 05:10 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 08:11:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot capture from kvm host. (23.86 KB, text/plain)
2012-04-20 05:51 EDT, Frank Murphy
no flags Details
Blkid : using working Kernel (799 bytes, text/plain)
2012-04-20 08:02 EDT, Frank Murphy
no flags Details
Grub2.cgf from said box (10.12 KB, text/plain)
2012-04-20 08:06 EDT, Frank Murphy
no flags Details
Crypttab from same kvm Guest (294 bytes, text/plain)
2012-04-20 08:07 EDT, Frank Murphy
no flags Details
boot capture from kvm host. (27.27 KB, text/plain)
2012-04-22 05:47 EDT, Frank Murphy
no flags Details
dmesg | less captured from kvm host (1.41 KB, text/plain)
2012-04-22 05:49 EDT, Frank Murphy
no flags Details
init.log captured from kvm host (1.17 KB, text/plain)
2012-04-22 05:50 EDT, Frank Murphy
no flags Details
dmesg | grep dracut captured from kvm host (1.35 KB, text/plain)
2012-04-22 05:59 EDT, Frank Murphy
no flags Details
bootup capture (220.62 KB, text/plain)
2012-04-23 06:33 EDT, Frank Murphy
no flags Details
/run/initramfs/init.log (1.17 KB, text/plain)
2012-04-23 06:34 EDT, Frank Murphy
no flags Details
fstab (980 bytes, text/plain)
2012-04-23 06:34 EDT, Frank Murphy
no flags Details
dmsetup ls --tree (326 bytes, text/plain)
2012-04-23 06:35 EDT, Frank Murphy
no flags Details
stderr from "dracut --debug -f test.img" (201.41 KB, application/x-xz)
2012-04-24 13:55 EDT, Paul Howarth
no flags Details

  None (edit)
Description Frank Murphy 2012-04-20 05:48:43 EDT
Description of problem: Can't complete boot, drops to debug shell.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install rawhide, upgrade to latest dracut, kernel, lvm
2.
3.
  
Actual results: no boot


Expected results: boot


Additional info:
Will get more info when back on the box, using a working kernel.
Comment 1 Frank Murphy 2012-04-20 05:51:39 EDT
Created attachment 578934 [details]
boot capture from kvm host.
Comment 2 Frank Murphy 2012-04-20 06:03:20 EDT
Booting
kernel-3.4.0-0.rc3.git0.1.fc18.i686
Non-Booting
kernel-3.4.0-0.rc3.git3.1.fc18.i686

dracut-018-25.git20120419.fc18.noarch
lvm2-2.02.95-6.fc18.i686
cryptsetup-1.4.2-1.fc18.i686
Comment 3 Frank Murphy 2012-04-20 07:49:49 EDT
https://fedoraproject.org/wiki/How_to_debug_Dracut_problems#Debugging

Can't get any more info, parted not found, blkid shows nothing
I can use "cd", but running blind, no "dir, locate".
Comment 4 Frank Murphy 2012-04-20 08:02:30 EDT
Created attachment 578983 [details]
Blkid : using working Kernel
Comment 5 Frank Murphy 2012-04-20 08:06:26 EDT
Created attachment 578985 [details]
Grub2.cgf from said box
Comment 6 Frank Murphy 2012-04-20 08:07:05 EDT
Created attachment 578986 [details]
Crypttab from same kvm Guest
Comment 7 Frank Murphy 2012-04-21 13:13:28 EDT
It appears to be a fight between cryptsetup and dracut.

If I bring both back to:
dracut-018-1.fc18
cryptsetup-1.4.1-2.fc17

then reinstall the non-booting kernel, it will boot.
The order both are installed also appears to be important.
cryptsetup before dracut.

So what has changed since I do not know.
Comment 8 Frank Murphy 2012-04-22 05:47:49 EDT
Created attachment 579270 [details]
boot capture from kvm host.

New capture with rd.shell rd.degug log_buf_len=1M
Comment 9 Frank Murphy 2012-04-22 05:49:18 EDT
Created attachment 579271 [details]
dmesg | less captured from kvm host
Comment 10 Frank Murphy 2012-04-22 05:50:32 EDT
Created attachment 579272 [details]
init.log captured from kvm host
Comment 11 Frank Murphy 2012-04-22 05:59:02 EDT
Created attachment 579273 [details]
dmesg | grep dracut  captured from kvm host
Comment 12 Harald Hoyer 2012-04-23 05:16:33 EDT
can you please give me your disk layout.

and the logs with "rd.shell quiet rd.debug log_buf_len=10M log_level=7"
Comment 13 Frank Murphy 2012-04-23 05:34:37 EDT
(In reply to comment #12)
> can you please give me your disk layout.

fstab ?

> 
> and the logs with "rd.shell quiet rd.debug log_buf_len=10M log_level=7"

will do give me about an hour.
Comment 14 Harald Hoyer 2012-04-23 06:08:40 EDT
# dmsetup ls --tree
fstab
Comment 15 Frank Murphy 2012-04-23 06:33:28 EDT
Created attachment 579475 [details]
bootup capture
Comment 16 Frank Murphy 2012-04-23 06:34:08 EDT
Created attachment 579476 [details]
/run/initramfs/init.log
Comment 17 Frank Murphy 2012-04-23 06:34:41 EDT
Created attachment 579477 [details]
fstab
Comment 18 Frank Murphy 2012-04-23 06:35:15 EDT
Created attachment 579478 [details]
dmsetup ls --tree
Comment 19 Harald Hoyer 2012-04-23 06:43:13 EDT
dracut: /init@113(): /lib/systemd/systemd-udevd --daemon --resolve-names=never
dracut: /init: line 113: /lib/systemd/systemd-udevd: No such file or directory

What is the output of:

# lsinitrd <failing initramfs image>  | fgrep udevd
# ls -l /lib/systemd/systemd-udevd /sbin/udevd
Comment 20 Frank Murphy 2012-04-23 06:55:24 EDT
# lsinitrd initramfs-3.4.0-0.rc3.git4.1.fc18.i686.img | fgrep udevd
-rwxr-xr-x   1 root     root       177560 Mar 18 19:40 usr/lib/udev/udevd
lrwxrwxrwx   1 root     root           19 Apr 23 10:43 usr/sbin/udevd -> /usr/lib/udev/udevd


ls -l /lib/systemd/systemd-udevd /sbin/udevd
ls: cannot access /lib/systemd/systemd-udevd: No such file or directory
ls: cannot access /sbin/udevd: No such file or directory
Comment 21 Milan Broz 2012-04-23 09:48:06 EDT
Breaks boot here as well - no lvm, no luks, just boot from plain ext4 partitions.

# lsinitrd /boot/initramfs-3.4.0-0.rc3.git4.1.fc18.x86_64.img | fgrep udevd
lrwxrwxrwx   1 root     root           19 Apr 23 12:56 usr/sbin/udevd -> /usr/lib/udev/udevd
-rwxr-xr-x   1 root     root       165976 Mar 18 20:40 usr/lib/udev/udevd

# ls -l /lib/systemd/systemd-udevd /sbin/udevd
ls: cannot access /lib/systemd/systemd-udevd: No such file or directory
ls: cannot access /sbin/udevd: No such file or directory

(where is the udevd these days? /usr/lib/udev/udevd ? :)
Comment 22 Michal Jaegermann 2012-04-23 15:37:47 EDT
(In reply to comment #21)
> Breaks boot here as well - no lvm, no luks, just boot from plain ext4
> partitions.

I cannot boot even "plain ext4 partitions" while using initramfs produced by either dracut-018-22.git20120418.fc18 or dracut-018-25.git20120419.fc18.  I am getting "line 113: /lib/systemd/systemd-udevd: No such file or directory" and after a long delay it drops me in a dracut shell.

OTOH after hacking init script on a broken iniramfs by replacing a line

/lib/systemd/systemd-udevd --daemon --resolve-names=never

with copied from a working init

udevd --daemon --resolve-names=never

I can boot again.
Comment 23 Michal Jaegermann 2012-04-23 16:15:05 EDT
I can confirm that after a change in /usr/lib/dracut/modules.d/99base/init.sh analogous to the one from comment #22 dracut-018-25.git20120419.fc18 produces initramfs which allows me to boot.
Comment 24 Frank Murphy 2012-04-24 04:25:22 EDT
Confirmed
Fix from https://bugzilla.redhat.com/show_bug.cgi?id=814625#c22
work with dracut --force <non-boot-initramfs>
and new installed kernel kernel-3.4.0-0.rc4.git0.1.fc18
Comment 25 Harald Hoyer 2012-04-24 10:09:51 EDT
please run with dracut-018-33.git20120424.fc18 installed:

# dracut -f test.img
# lsinitrd test.img  | fgrep udevd
Comment 26 Frank Murphy 2012-04-24 10:40:52 EDT
(In reply to comment #25)
> please run with dracut-018-33.git20120424.fc18 installed:
> 
> # dracut -f test.img
> # lsinitrd test.img  | fgrep udevd

Same error as OP.

rpm -q dracut && lsinitrd initramfs-3.4.0-0.rc4.git0.1.fc18.x86_64.img | fgrep udevd
dracut-018-25.git20120419.fc18.noarch
-rwxr-xr-x   1 root     root       165976 Mar 18 19:40 usr/lib/udev/udevd
lrwxrwxrwx   1 root     root           19 Apr 24 15:22 usr/sbin/udevd -> /usr/lib/udev/udevd
Comment 27 Frank Murphy 2012-04-24 10:43:05 EDT
Apologies forgot up update dracut, disregard comment 26
Comment 28 Frank Murphy 2012-04-24 11:10:59 EDT
Result stands however:

rpm -q dracut && 
lsinitrd initramfs-3.4.0-0.rc4.git0.1.fc18.x86_64.img | fgrep udevd

dracut-018-33.git20120424.fc18.noarch
-rwxr-xr-x   1 root     root       165976 Mar 18 19:40 usr/lib/udev/udevd
lrwxrwxrwx   1 root     root           19 Apr 24 15:50 usr/sbin/udevd -> /usr/lib/udev/udevd
Comment 29 Paul Howarth 2012-04-24 11:48:20 EDT
Same here:

# rpm -q dracut &&
  lsinitrd initramfs-3.4.0-0.rc3.git4.1.fc18.i686.PAE.img | fgrep udevd

dracut-018-33.git20120424.fc18.noarch
lrwxrwxrwx   1 root     root           19 Apr 24 16:43 usr/sbin/udevd -> /usr/lib/udev/udevd
-rwxr-xr-x   1 root     root       177560 Mar 18 19:40 usr/lib/udev/udevd
Comment 30 Harald Hoyer 2012-04-24 13:30:07 EDT
ok, one of you please attach the stderr output of:

# dracut --debug -f test.img
Comment 31 Paul Howarth 2012-04-24 13:55:26 EDT
Created attachment 579938 [details]
stderr from "dracut --debug -f test.img"

Here's the stderr output from my VM, which has no /lib/systemd/systemd-udevd (and "repoquery --whatprovides /lib/systemd/systemd-udevd" returns nothing too).
Comment 32 Paul Bolle 2012-04-25 05:15:47 EDT
(In reply to comment #22)

For what it's worth:

> [...] replacing [...]
> 
> /lib/systemd/systemd-udevd --daemon --resolve-names=never
> 
> with [...]
> 
> udevd --daemon --resolve-names=never

also leads to a, well, bootable initramfs with dracut-018-33.git20120424.fc18.noarch.
Comment 33 Harald Hoyer 2012-04-25 05:47:36 EDT
Can someone run this please?

$ ls -l /sbin/udevd; [ -x /sbin/udevd ] && echo OK || echo FAIL
Comment 34 Paul Bolle 2012-04-25 05:55:08 EDT
$ ls -l /sbin/udevd; [ -x /sbin/udevd ] && echo OK || echo FAIL
ls: cannot access /sbin/udevd: No such file or directory
FAIL
Comment 35 Paul Bolle 2012-04-25 05:57:45 EDT
And this can be found in the current initramfs:
$ cat /boot/initramfs-3.4.0-0.rc4.git0.1.fc18.i686.img | gunzip | cpio -t --quiet -v | grep udevd
-rwxr-xr-x   1 root     root       177560 Apr 25 10:48 usr/lib/udev/udevd
lrwxrwxrwx   1 root     root           19 Apr 25 10:48 usr/sbin/udevd -> /usr/lib/udev/udevd
Comment 36 Frank Murphy 2012-04-25 06:07:24 EDT
(In reply to comment #34)
> $ ls -l /sbin/udevd; [ -x /sbin/udevd ] && echo OK || echo FAIL
> ls: cannot access /sbin/udevd: No such file or directory
> FAIL

Same result
Comment 37 Frank Murphy 2012-04-25 06:22:11 EDT
Latest udev:
http://koji.fedoraproject.org/koji/buildinfo?buildID=307932

does not have /sbin/udevd as a file or even a symlink to it.
The only binary it provides is: /usr/bin/udevadm
most of files are in /usr/lib/*
Comment 38 Harald Hoyer 2012-04-25 09:35:53 EDT
please try: dracut-018-37.git20120425.fc18
Comment 39 Frank Murphy 2012-04-25 10:42:05 EDT
(In reply to comment #38)
> please try: dracut-018-37.git20120425.fc18

This works:
yum erase  kernel<newest> && yum install kernel<newest>
Comment 40 Paul Howarth 2012-04-25 11:20:54 EDT
Works for me too.
Comment 41 teramagazine 2012-12-20 09:30:55 EST
the solution for Vmware 

http://www.youtube.com/watch?v=ZjHLT7zm0QI
Comment 42 Harald Hoyer 2012-12-21 05:10:10 EST
(In reply to comment #41)
> the solution for Vmware 
> 
> http://www.youtube.com/watch?v=ZjHLT7zm0QI

so much time wasted watching the video for one simple setting

Note You need to log in before you can comment on or make changes to this bug.