Bug 814643 - "Words" corrupting (all) odt documents.
"Words" corrupting (all) odt documents.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: calligra (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedBlocker
: Patch, Triaged
Depends On:
Blocks: F17Blocker-kde
  Show dependency treegraph
 
Reported: 2012-04-20 06:27 EDT by Nikolai Maziashvili
Modified: 2012-04-28 20:58 EDT (History)
6 users (show)

See Also:
Fixed In Version: calligra-l10n-2.4.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 20:58:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kcrash information for calligra words (5.32 KB, application/octet-stream)
2012-04-23 14:05 EDT, Nikolai Maziashvili
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 298134 None None None Never

  None (edit)
Description Nikolai Maziashvili 2012-04-20 06:27:10 EDT
Description of problem:
Documents once opened and saved by Words (Calligra) can not be reopened by it, nor by LibreOffice-writer by the way. 
When opening error message is displayed:
"The manifest file seems to be corrupted. The document could not be opened."
Followed by following error message:
"Could not open /home/mkudro/test1.odt
Reason: Not a valid Calligra file: /home/mkudro/test1.odt"
Being "not a valid Calligra file" kind of funny, since file was created by Calligra-words :)


Version-Release number of selected component (if applicable):
Calligra-Words - 2.4.0

How reproducible:
Every time

Steps to Reproduce:
1. Create document with Words
2. Save it and try to reopen it.

or
1. Open with C-Words any document created by LO-writer
2. make even smallest change to it and save it.
3. try to reopen it by C-words or LO-writer
4. stop laughing at my weird abbreviations. 
  
Actual results:
Corrupted odt files.

Expected results:
not so much corrupted files :)

Additional info:
If needed, please let me know.
Comment 1 Rex Dieter 2012-04-20 08:57:32 EDT
Ugh, confirmed.  Seems not to happen on my f16 box with calligra-2.4.0, fwiw.
Comment 2 Rex Dieter 2012-04-20 09:12:11 EDT
http://rdieter.fedorapeople.org/calligra/

2 starter documents:  
yo-orig.odt
yo.odt

the former was created/saved using calligra-2.4.0 on my f16 box.

the latter was on my f17 box, opened -orig, added/removed some whitespace and resaved as yo.odt
Comment 3 Kevin Kofler 2012-04-20 09:30:58 EDT
So this happens on F17 and not on F16 with the same version of Calligra? Huh? Are the machines involved all x86_64?
Comment 4 Rex Dieter 2012-04-20 09:37:46 EDT
OK, see
http://bugs.kde.org/298134
and
https://git.reviewboard.kde.org/r/104677/
Comment 5 Nikolai Maziashvili 2012-04-20 10:11:04 EDT
(In reply to comment #3)
> So this happens on F17 and not on F16 with the same version of Calligra? Huh?
> Are the machines involved all x86_64?

Hi Kevin - In my case yes, machine is x86_64.

@Rex
Thnx for upstream links. Good to know that KDE devs are grinding through metal now. 

It is amazing to see how polished and pleasant to work with Koffice has become....this bug aside ;)
Comment 6 Fedora Update System 2012-04-20 11:03:27 EDT
calligra-2.4.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/calligra-2.4.0-4.fc17
Comment 7 Adam Williamson 2012-04-20 15:03:06 EDT
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . Accepted as a blocker per criteria "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items" and "All known bugs that can cause corruption of user data must be fixed or documented at Common F17 bugs".
Comment 8 Fedora Update System 2012-04-21 17:06:20 EDT
Package calligra-l10n-2.4.1-1.fc17, calligra-2.4.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing calligra-l10n-2.4.1-1.fc17 calligra-2.4.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6339/calligra-l10n-2.4.1-1.fc17,calligra-2.4.1-1.fc17
then log in and leave karma (feedback).
Comment 9 Nikolai Maziashvili 2012-04-22 09:03:51 EDT
mmmm....kind of a funny thing...calligra (words) syg-faulting on any action: open documents, create documents....after latest update. 
I wil try to get gebug info.
Comment 10 Rex Dieter 2012-04-22 21:14:29 EDT
2.4.1-1 seems to work charmingly well on my f17 x86_64 box at least.
Comment 11 Nikolai Maziashvili 2012-04-23 14:03:45 EDT
(In reply to comment #10)
> 2.4.1-1 seems to work charmingly well on my f17 x86_64 box at least.

Strange endeed. I'm getting constant sygfaulting... Getting following:

words(1775)/koffice (lib kopageapp) KoOdfLoadingContext::KoOdfLoadingContext: could not parse manifest document 


I am attaching kcrash output, it is single start kcrash. I did installed calligra-debuginfo, but still couldn't get more then one star for debug quality :)
Comment 12 Nikolai Maziashvili 2012-04-23 14:05:07 EDT
Created attachment 579642 [details]
kcrash information for calligra words

calligrawords sygfaulting all the time whenever i try to open or create document.
Comment 13 Nikolai Maziashvili 2012-04-28 06:33:05 EDT
Hi Rex, maybe it would be better to open a new ticket regarding my latest problems with Words, and close this one since this issue was already resolved.
Comment 14 Rex Dieter 2012-04-28 09:54:57 EDT
I agree.
Comment 15 Rex Dieter 2012-04-28 09:55:46 EDT
preferably upstream @ bugs.kde.org if you don't mind too.
Comment 16 Kevin Kofler 2012-04-28 16:40:58 EDT
How widely reproducible is the crash? If Words is completely unusable for a significant portion of our users, that's a release blocker and should be tracked as such in Fedora Bugzilla.
Comment 17 Kevin Kofler 2012-04-28 16:41:44 EDT
(in addition to the upstream report, which is definitely needed)
Comment 18 Fedora Update System 2012-04-28 20:58:57 EDT
calligra-l10n-2.4.1-1.fc17, calligra-2.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.