Bug 814684 - [virtio-win][block] qemu-kvm stopped w/ io-error when initialize readonly disk in win2k8R2
[virtio-win][block] qemu-kvm stopped w/ io-error when initialize readonly dis...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 08:09 EDT by Yang Zhao
Modified: 2013-02-21 05:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:38:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yang Zhao 2012-04-20 08:09:51 EDT
Description of problem:
qemu-kvm stopped w/ io-error when initialize readonly disk in win2k8R2

Version-Release number of selected component (if applicable):
2.6.32-259.el6.x86_64
qemu-kvm-0.12.1.2-2.270.el6.x86_64
seabios-0.6.1.2-19.el6.x86_64
virtio-win-prewhql-26
win2k8R2 guests

How reproducible:
100%

Steps to Reproduce:
1.Start win2k8r2 guest w/ readonly disk .
eg:/usr/libexec/qemu-kvm -M rhel6.3.0 -enable-kvm -m 1G -smp 4,sockets=4,cores=1,threads=1 -name win2k8-32 -uuid e2eaca3e-e764-f57b-22f0-74f4ab8c4965 -monitor stdio -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/root/win2k8-64,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -net none -spice port=5910,disable-ticketing -vga qxl -drive file=disk28,if=none,id=drive-disk28,format=qcow2,cache=none,werror=stop,rerror=stop,readonly=on -device virtio-blk-pci,id=disk28,drive=drive-disk28
2.in the guest,click computer->manage->Storage->Disk Management.Guest prompts "Initializae Disk Wizards" ---> Click OK
3.do (qemu)cont a loop 


Actual results:
After step2 , qemu-kvm paused due to io-error
After step3 , qemu-kvm always in pause status w/ io-error ,and can not change to running status .
eg:
(qemu) cont
(qemu) block I/O error in device 'drive-disk28': Permission denied (13)
handle_dev_stop: stop


Expected results:
Guest keeps running 

Additional info:
Tried on win7-64 bit guests ,sometimes can hit this bug .sometimes guest prompts "The request could not be performed because of an I/O device error"
Comment 2 Vadim Rozenfeld 2012-10-05 05:23:59 EDT
Please make sure that you have viostor driver properly installed.
If you uprated MS signed driver with a RH signed (pre-whql) one -
it will not work. In this case just try reproducing the problem on a freshly installed system. I cannot reproduce this issue while testing viostor driver from the recent builds.

Thank you,
Vadim.
Comment 3 dawu 2012-10-14 05:33:59 EDT
Since build 26 had been deleted from brew site, try to reproduce this issue on the latest build virtio-win-prewhql-41 with the same steps in comment0

CLI: /usr/libexec/qemu-kvm -cpu host -m 2G -smp 2 -boot dc -drive file=win2k8-R2-blk.qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none,format=qcow2,media=disk -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup0 -device e1000,netdev=hostnet0,mac=00:22:5a:13:78:06,bus=pci.0,addr=0x4,id=net0 -uuid b2b6f616-0b80-4b41-af4e-985737e9ffbf -vnc :1 -rtc base=localtime,clock=host,driftfix=slew -bios /usr/share/seabios/bios-pm.bin -monitor stdio -drive file=disk1.qcow2,format=qcow2,if=none,id=drive-virtio0,werror=stop,rerror=stop,readonly=on -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0

Actually Results:
On version virtio-win-prewhql-41, read-only virtio disk can not be initialized with related item is disabled. And no any error or hang happened.


Based on above, this issue can not reproduce.

Best Regards,
Dawn
Comment 4 Mike Cao 2012-10-22 01:59:25 EDT
Based on comment #3 ,move status to VERIFIED
Comment 5 errata-xmlrpc 2013-02-21 05:38:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.